locked
Error 401, when trying to authenticate from server's local IE RRS feed

  • Question

  • Recently redeployed 4.0, restored from backup (server reinstall).

     

    Everything seem to work fine. Except one thing: I cannot login to CRM from the server.

    Server roles - AD DC (one of two), SQL and CRM/IIS in one.

     

    I can log in to CRM from any computer, even from the other AD DC server, but not from the CRM server.

    Its added into Intranet Sites in IE. Tried all options of authentication (prompt, automatic etc.), still it does not log in when right username and password are entered.

     

    After three attempts, it goes to the 401 page:

    HTTP Error 401.1 - Unauthorized
    You do not have permission to view this directory or page using the credentials that you supplied.

     

    It also keeps adding wrong domain name (part of the host name) to username.

    E.G. if domain where users belong, and which is set as default place to authenticate users is "codomain".

    Host name of server is http://crm.companyname.com/.

    After providing just user/password (without domain), it puts CRM\user / password in the second attempt window.

     

     

    If I do provide domain - codomain\user / password it leaves the codomain\user in second attempt window, but does not log me in, still. Same 401 page.

     

    What could this be?

     

    Thursday, November 6, 2008 5:41 PM

All replies

  • Hi,

    Did you Enable Integrated Windows Authentication in Internet Explorer?


    Thursday, November 6, 2008 8:46 PM
  • It is because of Registry.

     

    To solve this from Registry go to :

     

     

     

    HKEY_LOCAL_MACHINE --> SYSTEM --> CURRENT CONTROL SET --> CONTROL --> LSA --> 

     

    RightClick and create a new DWORD 32 bit value and give the name as DisableLoopbackCheck and then modify it to give its value as 1 (Either Decimal or Hex) doesnt matter.

     

    Then restart the system to see it works fine..

     

     

    Hope this solves ur problem.

    Friday, November 7, 2008 11:00 PM