CRM 2013: CampaignActivity - Recipients not found/"regardingobjectid" is null in activitypointer table RRS feed

  • Question

  • I´m working on a migration from a CRM 4.0 to 2013. In the former
    system we have some functions which access the recipients of a e-mail
    campaign activity via the activityid. This was, for example,  done by
    joining the activitypointer and activityparty like this:
        <fetch mapping="logical" >
            <entity name="activitypointer" >
                <attribute name="activityid" />
    <condition attribute="regardingobjectid" operator="eq"
    value="d6d3c79c-        0a9a-e311-80d7-000c2982ff89" />
                    <link-entity name="activityparty" from="activityid" to="activityid" >
                            <condition attribute="partyid" operator="eq" value="fa0fa058-0a9a-    e311-80d7-000c2982ff89" />
                    <link-entity name="email" from="activityid" to="activityid" >
                        <link-entity name="campaignactivity" from="activityid"     to="regardingobjectid" >
                        <attribute name="subject" />
                        <link-entity name="campaign" from="campaignid" to="regardingobjectid" >
                            <attribute name="campaignid" />
    CRM 2013 I find now, that the recipients are not registered in the
    activityparty table. If I look in this, I find only two references: one
    for the campaignactivity and one for the systemuser. Although I checked
    the "Track Activities" Checkbox in the confirmation window of the Mail
    Merge process. Does anyone know if changes have been made to handling
    the activity parties in CRM 2013?

    A deeper search brought up that the
    activities are tracked, but the regardingobjectid in activityparties -
    which should referr to the activity - is empty. So there is no
    relation now between the activity and the activity parties.. which is
    really weird and a problem for me now.

    • Edited by morebeat Thursday, February 20, 2014 12:16 PM
    Thursday, February 20, 2014 10:53 AM