Problems with Bing Translator: "Message: to is required Line: 2 Char: 43729 Code: 0" RRS feed

  • Question

  • I tried using the Bing Translator widget. It looks simple enough, cut & paste the code. However, I only see the Translator button on the webpage. When I try to click on t, nothing happens (?).  Please see error message below.  Do you know what's going on? Thanks for the help

    Error message:

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; InfoPath.3)
    Timestamp: Mon, 27 Oct 2014 12:33:34 UTC

    Message: to is required
    Line: 2
    Char: 43729
    Code: 0

    Tuesday, October 28, 2014 12:44 AM

All replies

  • Hi there,

    Information on how to use the Translator widget can be found here:


    Can you post the exact HTML snippet you use?

    Best regards,

       Christian Federmann

       Microsoft Translator Team

    Microsoft Translator team - www.microsoft.com/Translator

    Monday, November 3, 2014 10:41 PM
  • I am having the exact same problem. The Translate widget used to work, but when I checked it recently, I was getting the following error:

    Error: Error: to is required
    Source File: http://www.microsofttranslator.com/ajax/v3/WidgetV3.ashx?siteData=ueOIGRSKkd965FeEGM5JtQ**&ctf=True&ui=true&settings=Manual&from=en
    Line: 2

    Here is the code I am using:

    <div id='MicrosoftTranslatorWidget' class='Dark' style='color:white;background-color:#555555'></div><script type='text/javascript'>setTimeout(function(){{var s=document.createElement('script');s.type='text/javascript';s.charset='UTF-8';s.src=((location && location.href && location.href.indexOf('https') == 0)?'https://ssl.microsofttranslator.com':'http://www.microsofttranslator.com')+'/ajax/v3/WidgetV3.ashx?siteData=ueOIGRSKkd965FeEGM5JtQ**&ctf=True&ui=true&settings=Manual&from=en';var p=document.getElementsByTagName('head')[0]||document.documentElement;p.insertBefore(s,p.firstChild); }},0);</script>

    Can you fix this? Thanks in advance.

    Monday, November 10, 2014 1:08 PM