locked
CRM 2011 Dialog Issue RRS feed

  • Question

  • Hi all, I have created a dialog and I need to make it visible to all users. Right now I have tried every possible combination of permissions and I am sure that the problem is not permissions because I have 2 users with "System Administrator" Permission and I am creating the dialog from one user but the other can't see it even by having System administrator as permission. This said, I tried also assigning the dialog to the other user or sharing it with all the users including the other user that is system administrator but they still can't see the dialog.

    The dialog is related to the lead entity and when they go to the Lead view, highlight a lead from the leads list and click on "Start Dialog" , the view of "On-Demand" Dialogs doesn't show the dialog and it's completely empty. It works only for the Administrator user. The other users don't find the dialog there. The dialog is in "Activated" status, assigned to the admin user that is the one that created it, shared with all users and still the only to see it is the Admin user.

    The other users have correct permissions on all entities involved and one of them as I previously said is also System Administrator.

    Open to any suggestion.

    Thank you in advance,

    Ermal

    Thursday, December 13, 2012 6:45 PM

Answers

  • Thank you all.

    This was my fault but I had no idea of this and never thought that the problem was the language. I had the English language set for the Administrator that was creating the dialog and the other users had Italian language set as their user language and they weren't able to see the dialog since it was created from a user with the English language. The strange thing is that language is not defined in the dialog and can't be decided by me or I haven't found that option yet, anyway I solved the problem when I saw the View Filter. Now I used an unsupported way of setting the language to -1 in the database for that specific dialog but I don't understand why Microsoft doesn't provide the possibility to choose the dialog language as they do in the Reports.

    If anyone knows if there is a supported way for this, please let me know.

    Thanks,

    Ermal

    • Marked as answer by Ermal Llanaj Monday, December 17, 2012 11:09 AM
    Monday, December 17, 2012 11:09 AM

All replies

  • Hi Ermal,

    Have you set the dialog as viewable by: Organization?

    If so can you post a screenshot of the whole dialog?

    Thanks

    Paul

    Thursday, December 13, 2012 6:57 PM
  • Hi Paul,

    I haven't found any option that sets the dialog viewable by the organization. I know that it exists for the reports but not for the dialog. I have the Administrator as the owner and I tried even sharing the dialog with everyone by giving all permissions when sharing but still the problem was not solved.

    Below you will find the screenshot of the dialog. it is related to a custom entity that has relationships with the Contact and Account entities. The users have permissions for both Contact and Account entities and also full permissions for the Custom entity, including all "Read", "Write" "Delete" and also "Append", "Append to" , "Share" and "Assign" permissions.

    They also have permissions on the Process, System Job and Dialog Sessions in the Customization TAB.

    Thank you.

    Ermal

    Friday, December 14, 2012 9:25 AM
  • Hallo Ermal,

    you wrote, that the dialog should be related to the lead entity. 

    But when you have a look at the screenshot: the entity is 'stage'. Is stage your label for lead or is it an other entity?  


    Herzliche Grüße / Best regards Markus Müller If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Friday, December 14, 2012 12:27 PM
  • Hi Markus,

    I am working and trying on different things and I showed another dialog but my problem is the same. It's just the wrong screenshot, related to another custom entity, but the problem persists in both Lead and Stage Dialogs.

    Here you go, below you will find the screenshot for the Lead dialog. Sorry for the confusion. anyway the problem persists here too. Oh, and I know it's in "Draft" so the problem that is not showing is not the "Draft" status, but I am working on them and that's why it is disabled here in the screenshot.

    Friday, December 14, 2012 2:16 PM
  • Oh my mistake, the viewable by option is only on workflows, not dialogs.

    From what you are describing, it sounds like this is either permissions related, or that the dialog is not activited or running on the right entity -- however you have confirmed it is not permissions related since you have a system admin not able to see it either, and we can see the correct entity is being used, and that you are activating it.

    There's nothing else that would prevent users from seeing those dialogs, so I would suggest just double checking everything to be sure. Make sure the other admin definitely has the System Administrator security role, and that other users have Organization Read access to the Process entity. If you're not checking each user directly, make sure they're doing it correctly, or do it with them.

    Sorry I couldn't be of more help, this is a very strange problem.

    Paul

    Friday, December 14, 2012 8:01 PM
  • Thank you all.

    This was my fault but I had no idea of this and never thought that the problem was the language. I had the English language set for the Administrator that was creating the dialog and the other users had Italian language set as their user language and they weren't able to see the dialog since it was created from a user with the English language. The strange thing is that language is not defined in the dialog and can't be decided by me or I haven't found that option yet, anyway I solved the problem when I saw the View Filter. Now I used an unsupported way of setting the language to -1 in the database for that specific dialog but I don't understand why Microsoft doesn't provide the possibility to choose the dialog language as they do in the Reports.

    If anyone knows if there is a supported way for this, please let me know.

    Thanks,

    Ermal

    • Marked as answer by Ermal Llanaj Monday, December 17, 2012 11:09 AM
    Monday, December 17, 2012 11:09 AM