locked
CRM Error (Object reference error) on logging in to CRM 2013 instance. RRS feed

  • Question

  • Hi All,

    Can anyone help me resolving the below issue? Any help is appreciated, thanks.

    There are 3 organizations in my MS CRM server and all were working properly. Suddenly, all the organizations stopped working throwing an error "Object reference not set to an instance of an object". This error is seen when loading the CRM instance (see screenshot).

    - Verified the space in the database and CRM server and no issue with it.

    - Restarted iis, SQL services and also restarted the server but no luck.

    We couldn't get clue on what went wrong and blocked. Please let me know any of your views on the issue.

    Please find below for the error details found in the Event Viewer and the screenshot.

    Error:

    Exception generated at: 23/1/2017 10:44:55 AM
    Error Type: System.NullReferenceException
    Error Message: Object reference not set to an instance of an object.
    Error Stack Trace: 
    at SingleSession.createSqlConn()  ilOffset = 0x5
    at SingleSession.get_session_status(String username, String sessionid)  ilOffset = 0x5B
    at SingleSession.context_PostAuthenticateRequest(Object sender, EventArgs e)  ilOffset = 0xD7
    at SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()  ilOffset = 0x58
    at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)  ilOffset = 0x15


    Stack Frame: 

    at EventHandler.Invoke(Object sender, EventArgs e)  ilOffset = 0xFFFFFFFF
    at HttpApplication.RaiseOnError()  ilOffset = 0x21
    at ApplicationStepManager.ResumeSteps(Exception error)  ilOffset = 0x85
    at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)  ilOffset = 0x5C
    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)  ilOffset = 0x16A
    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)  ilOffset = 0x4B


    Exception Data: 
    1: Key type: System.String, value: ASPIMPERSONATING
    1: Value type: System.String, value: 

    Monday, January 23, 2017 3:11 AM

All replies

  • Has the account managing the IIS side of the system be changed or deactivated?
    Thursday, February 9, 2017 1:39 PM
  • Enable Tracing on CRM Web Server and check if you get any more details about the error.

    MaKeer

    Thursday, February 9, 2017 9:51 PM
  • This issue was due to a change done in CRM webconfig file to accommodate the functionality for a portal. Doing the appropriate changes in the CRM webconfig, the issue was resolved.

    Thursday, March 9, 2017 6:29 AM