locked
MoneyLink Problem RRS feed

  • Question

  • I was working in a macro which had nothing to do with MSMoney, the ribbon, command bars.  It had only to do with using the CMD window to read a listing of folders and subfolders.

    All of a sudden, I began getting errors from my MoneyLink addin with the Set Command line being highlighted

    The error occurs upon opening an excel file, and again on closing the file.  The Add-ins ribbon does not show up.

    ' Wrapper function which passes back the command bar item with the specified name on the given
    ' command bar. This function returns True if the item was found, False if not.
    '
    Private Function GetCommandBarItem(cb As CommandBar, CommandBarItemName As String, Command As CommandBarControl) As Boolean
        On Error Resume Next
        Set Command = cb.Controls.Item(CommandBarItemName)
        GetCommandBarItem = (Err.Number = 0)
    End Function

    I have tried Excel in SafeMode, and also uninstalled and reinstalled the MoneyLink add-in (a full uninstall -- not just deselecting the box; and the re-install was from a fresh download).

    Any thoughts as to how to fix this?

    Thanks.

    EDIT: The problem with the crashing was that I had set the VBE to break on ALL errors; rather than break on UNHANDLED errors

    However, the MoneyLink options are still not showing up on a ribbon, as they used to.  I don't know how long that has been going on, as it has been a while since I have used this add-in.  BTW, I am running Office365/Excel2016 32 bit on Windows 10 64 bit.


    Ron





    Friday, July 21, 2017 12:41 PM

All replies

  • I don't know why the toolbar/ribbon tab disappeared, but I created a new one using the Customize Ribbon option in Excel 2016.  I chose to add a new tab to the Data ribbon, which I named MoneyLink.  In the Choose commands from dropdown I chose Macros.  I then added

    • InsertMoneyQuery
    • RefreshAllMoneyQueries
    • RefreshSelectedMoneyQueries

    to that tab.  The queries can be renamed as you wish.

    Still don't understand why the built-in method stopped working.  It does use the CommandBar object and this is no longer being used, but still.


    Ron

    Saturday, July 22, 2017 1:12 PM