locked
Volume D: is now RAW not anymore NTFS ! Help ! RRS feed

  • Question

  • Could one of you help me in indicating the right procedure to follow ?

    I explain.

    I've suddenly got thousands of errors in my event viewer and my homeserver went red (Network critical).
    "Volume D: is failing". Full of demigrator errors.
    And yes right my volume D: is completely lost. Empty.
    Chkdsk gives me: the volume is RAW. It cannot check anything...

    I then decided to format the volume D again (quick format through the disk management) and I now have demigrator errors and the console showing me 3.6 terabytes of system (not anymore files).

    WHS has lost all of his thombstones apparently.

    So what to do ?
    A server reinstall ? If yes, will it work as the D volume is empty ? Will it found again all my data on all my other disks ?

    Thank you for your help

    Monday, November 17, 2008 7:46 PM

All replies

  • Hi Patrick,
    ugly experience, I still would like to know, what is causing this, since I have experienced the same short after rolling from PP1 Beta to PP1 final release. D: drive was corrupt with some circular references, Vista RE command prompt still was able to read the most of it.
    To perform a server reinstall (or try, if you get the choice offered without a valid drive D:), I would recommend to use a Vista DVD or remove the system disk and attach it to a client PC and clean it, as described here. Or take a spare harddisk for trying.
    Attach the disk back to the server after that (if removed before) and try, if you get a reinstall offered.
    If you don't get this offer, but only a new install, disconnect all your data disks.
    After completing the installation and all upgrades, attach the first disk, logon locally, open the hidden folder DE\shares on the disk and copy the files from the subfolders to the subfolders on the new installation via shortcut Shared folders on server, which you will find on the desktop.
    After completing, you can add this disk to the storage pool. Shut down and attach the next data disk and so on.
    Best greetings from Germany
    Olaf
    Monday, November 17, 2008 8:06 PM
    Moderator
  •  I will try tomorrow to reinstall my whs.
    The reasons why my D: volume became RAw is very unclear.
    Everything was working fine since months. I didn't install anything since weeks (no special add-ins).
    Not even copied files to my WHS when it happened.

    The only thing that I got was VolSnap errors since weeks (vss cannot grow type of errors) on that particular disk.
    But I have that as well on other without issues.
    Maybe it is linked to that...

    Monday, November 17, 2008 8:35 PM
  • OKay.....
    Tried the Server Reinstallation without success.
    This Reinstallation option for me is really not good. Not truly tested by the WHS team, for me, this is not possible.

    Example. I've spent hours to understand why this damn Re-install option was not appearing when I was booting from the WHS CD.
    Why ? Because the System Partition disk was not listed in the setup has the Disk O... but as Disk 3, sometimes 2, etc.
    After 10 reboots, it suddenly appears as DIsk 0 and the Server Reinstallation option appeared.
    Pfff....

    Nevertheless, even if the Reinstall option worked smoothly, it never get back the Data that are on all my disks.
    All my shares, etc were OK, the console gave me 5.6 TB of disk but 0 bytes of data.
    No way to make WHS launch the rebuild of thombstones.

    I decided to go for a complete full new installation...

    Wonderful...
    What a unreliable product this WHS.
    I love it , but I have to admit that IT IS NOT MADE FOR HOME USERS !!!!
    In one year, I had 2 or 3 issues with my brand new machine and disks.
    If I was a home user, I would never never recover my machine.

    I was recommending WHS to some of my friends with basic knowledge of computers.
    I will stop... right now.

    To finish that discussion, just to mention that if you loose or corrupt your D partition located on your System disk...then your only option is to reinstall everything from scratch and then apply the method given by Olaf just above.

    Tuesday, November 18, 2008 5:05 PM