locked
Get "Requesting access to this computer" message on the PC I want to connect to RRS feed

  • Question

  • Just this past weekend, I set up all my computers on Live Mesh, and on one computer, I get the following message on the screen if I try to connect to it via one of the others:

    "Matthew C is requesting access to this computer. Click "allow" to end your session and grant access, or click "Deny" to continue working.  If you do nothing, you will be disconnected in 30 seconds."

    Here is a screenshot of it.

    Unless "Allow" is clicked (which would be impossible if I weren't at home!), I cannot access the screen of this PC.
    I thought it might have something to do with the User Account settings, but I've played with those, and this message still appears.  Ironically, it is this PC that I would most want to connect to while away!

    The PC is a HP laptop running Win XP Home.  Please let me know if there is any other info you might need to help troubleshoot and I will provide.  Thanks!
    Wednesday, December 3, 2008 7:42 PM

Answers

  • Hi,

    That message pops up to allow someone working on the remote computer to deny the Live Mesh Remote Desktop request.  If no action is taken within 30 seconds, the default is "Allow" - i.e., the remote session will be initiated.

    Ben.
    Thursday, December 4, 2008 5:10 PM

All replies

  • So if you wait 30 seconds and don't click "Allow" on the XP Home box, it doesn't connect eventually? I've seen the message on my Win XP Pro SP3 system, but after 30 seconds, I can get the remote access. It locks the remote machine (which would be your XP Home box).

    If it doesn't connect, what happens? Does your remote connection drop, or just never actually connect, or what? I'll bet Ben will ask for your log files

    Thursday, December 4, 2008 1:11 AM
  • Hi,

    That message pops up to allow someone working on the remote computer to deny the Live Mesh Remote Desktop request.  If no action is taken within 30 seconds, the default is "Allow" - i.e., the remote session will be initiated.

    Ben.
    Thursday, December 4, 2008 5:10 PM
  • Oh, I feel like SUCH a dummy!!!  I guess what through me off was that I didn't see that same message on my other Desktop PC - it just connected without that 30 second prompt.  Would that have anything to do with the fact that the laptop is running XP Home and the Desktop XP Pro?

    Thanks for helping me through a non-existent issue!  :)

    On a side note, I am the editor of Windows Mobile Louisville, and would love to be part of the Live Mesh Mobile tests!  Eager to plug the mobile capabilities on my site!  :)

    Matt
    Thursday, December 4, 2008 6:18 PM
  • Hi Matt,

    Don't worry about it.  That experience is ... well, let's just say you're not the first person to think that someone needed to click "Allow" on the remote machine for the connection to initiate. ;)  Hopefully we can make the experience more transparent in the future.

    As for Live Mesh for Mobile: We'll be adding more spots as soon as we can, and we'll let everyone know when we do.  Keep your eyes on our Mobile forum and our blog!

    Thanks,

    Ben.
    Thursday, December 4, 2008 7:54 PM
  • Actually, I think that the experience is that you see the 30 second prompt on the "target" machine if you are logged in and actively using the system. If that machine is locked, or does not have a user logged on, then you don't see that prompt and the connection happens faster. Since the target machine (the one you connect to) gets locked when the remote connection is established, I think that 30 second timeout gives an active user the option to prevent losing his session. So if you're going to connect remotely, you might want to consider having your machines automatically lock (use the screen saver option), or make sure you lock the machine (or log off) when you leave it.

    Or start your remote connection, go get a coffee, and then come back and sign in.
    Thursday, December 4, 2008 8:12 PM