locked
Speech server + IPBX RRS feed

  • Question

  • Good day,
    I hope someone can help with a quick question.

    I currently have speech server beta on a virtual machine running XP.

    I can currently call my speech server using my soft phone (sipxphone) and that all works fine.

    Now for the tricky part. Unless I am mistaken I can only talk to the speech server using TCP and not UDP it’s why sipxphone works so well as it was one of the few soft phones to do this.

    I need to be able to call my speech server using my hardware voip phones (SPA942) and no matter what I try nothing will work so I can only assume they use UDP.

    So as I see it I need to install a IPBX call the IPBX from my hardware phone and let that talk to speech server (as the IPBX would use TCP). I have installed various IPBX's and I am currently testing PBXNSIP (http://www.pbxnsip.com/ ) this has an exchange 2007 UM interface so SHOULD talk to speech server the same way and handle TCP/SIP the same way.

     

     

    I can happily register my SPA942 on my IPBX as extension 100 but for what ever reason calls to my speech server are not going through. I think I need to add the speech server as an extension onto the IPBX so I can just dial “101” for example and go straight to it. I did some research into this and for the life of me can’t figure out how to do it.

     

    Also, I assume the only config needed on the Speech server side of things is to add the IP / Port of the IPBX as a trusted peer?

     

    The reason I am trying to go through an IPBX is (and trust me I don’t want to do this) because I cant for what ever reason dial my speech server p2p from my hardware phone using the SIP url. But I can do this from my softphone.

     

    So in conclusion has anyone setup Speech server to play nicely with a PBX and register it as an extension. Or has anyone managed to call directly (using the IP) of the speech server from a hardware phone? If so what hardware phone did you use?

    Thanks in advance for any help.

     

     

     

    Thursday, July 19, 2007 9:51 AM

All replies

  • Hi Ross,

     

    Can you update this Post? Have you implemented the RTM version and confirmed this is still an issue.?

    Wednesday, September 19, 2007 6:46 PM