locked
http 401.1 unauthorized. You do not have permission to view this directory or page using to the credentials you supplied. RRS feed

  • Question

  • Hi all,

    I use a user account in group admin domain role and admin local role to import licence to my CRM server. when I try to go on local server : http://crm.domain.com/MSCRMServices/ but it get error msg "http 401.1 unauthorized. You do not have permission to view this directory or page using to the credentials you supplied." 

    http://img7.imageshack.us/img7/9417/crmerror44.png

     

    Try on client machine get other msg : "

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable."

    http://img64.imageshack.us/img64/3155/crmerror5.png

    Do I miss config somthing ? Does anyone can help me pls ?

    Regards

    Vinh Nguyen

    Thursday, November 4, 2010 2:21 AM

Answers

  • Vinh,

    In Pic 2 you have displayed the Authentication settings. You have enabled Anonymous and Disabled Windows Authentication. This is one of the reasons why you are experiencing the issue.

    Disable Anonymous Authentication and Enable Windows Authentication.

    Your IIS Authentication settings should look like this:

    -http://img709.imageshack.us/img709/8969/iisauth.png


    Regards,

    ITonit Support

    Support@itonit.com

    Http://ITonit.com

    MSCRM Consultants
    • Proposed as answer by ITonit.com Friday, November 5, 2010 11:02 PM
    • Marked as answer by Jim Glass Jr Monday, November 8, 2010 4:08 PM
    Friday, November 5, 2010 7:14 PM

All replies

  • Vinh,

    401.1 unauthorized is a likely cause of incorrect credentials or the Authentication fails due to various reasons. The most common reason is Kerberos.
    - In the image provided (link 1) I see you are accesing port 80
    - Are you using http://CRMServerName or a Host header attached to Bind port 80 on CRM website?
    - Please look at the suggestions on the error received (link 1)

    Let me know your IIS AppPool Identity and WebSite Authentication settings to further troubleshoot.


    Regards,

    ITonit Support

    Support@itonit.com

    Http://ITonit.com

    MSCRM Consultants
    Thursday, November 4, 2010 5:01 PM
  • Is this user is a part of privusers group created by crm installation in AD.? if not, add him.

    or use the installation user (user who install the CRM) to achieve this task.

     

    I hope it helps.


    Amreek singh Senior CRM Consultant CDC Praxa Sydney, Australia http://mscrmshop.blogspot.com
    Friday, November 5, 2010 1:04 AM
  • ITonit,

    - I do access crm by 80 port http://crm.domain.com:80 already add Bind on IIS

    Pls check img that your request:
    http://img202.imageshack.us/img202/5502/apppool.png
    http://img585.imageshack.us/img585/9985/authen.png

     

    Amreek,

    Make sure I use the user account have domain admin and admin local role. And it on privusers group also.

    Regards,

    Vinh Nguyen

    Friday, November 5, 2010 4:45 AM
  • Vinh,

    In Pic 2 you have displayed the Authentication settings. You have enabled Anonymous and Disabled Windows Authentication. This is one of the reasons why you are experiencing the issue.

    Disable Anonymous Authentication and Enable Windows Authentication.

    Your IIS Authentication settings should look like this:

    -http://img709.imageshack.us/img709/8969/iisauth.png


    Regards,

    ITonit Support

    Support@itonit.com

    Http://ITonit.com

    MSCRM Consultants
    • Proposed as answer by ITonit.com Friday, November 5, 2010 11:02 PM
    • Marked as answer by Jim Glass Jr Monday, November 8, 2010 4:08 PM
    Friday, November 5, 2010 7:14 PM
  • Hi ITonit,

    http://img522.imageshack.us/img522/1870/authenerr.png

    Regards,

    Vinh Nguyen

    Saturday, November 6, 2010 10:27 AM