locked
problem updating fields in word 2008 for mac RRS feed

  • Question

  • When I update cross references in word 2008 for mac all of my figures and captions get duplicated and paragraphs containing the cross references gets converted to captions.  How do I stop this?
    • Moved by Max Meng Tuesday, January 29, 2013 9:49 AM
    Friday, January 18, 2013 4:39 AM

Answers

  • Assuming that MacWord resembles WinWord in dealing with cross-references, this isn't necessarily a bug...

    When you use Word's cross-reference feature, the cross-referenced paragraph will be enclosed in a bookmark. Later, if you add a paragraph by pressing Enter at the beginning of a bookmarked paragraph, the bookmark expands to include the new paragraph. (You can see this if you experiment with ordinary, visible, bookmarks; you can choose to display bookmarks in the Word Options dialog box.)

    The workaround is to recreate the cross-references immediately after you have noticed the problem. (Alternatively, you can redefine bookmarks, but it's a bit convoluted and, it seems, less predictable in recent versions of Word.)

    To avoid the problem in the first place, avoid pressing Enter (or adding text) at the beginning of a bookmarked/cross-referenced paragraph. Instead, do so at the end of the preceding paragraph instead.


    Stefan Blom, Microsoft Word MVP



    Friday, January 18, 2013 12:38 PM
  • For Mac Word I would try the following groups:
    http://answers.microsoft.com/en-us/mac/forum/macword

    and specificlly for Mac Word 2008, 

    http://answers.microsoft.com/en-us/mac/forum/macoffice2008-macword


    Peter Jamieson

    Friday, January 18, 2013 10:15 PM

All replies

  • Assuming that MacWord resembles WinWord in dealing with cross-references, this isn't necessarily a bug...

    When you use Word's cross-reference feature, the cross-referenced paragraph will be enclosed in a bookmark. Later, if you add a paragraph by pressing Enter at the beginning of a bookmarked paragraph, the bookmark expands to include the new paragraph. (You can see this if you experiment with ordinary, visible, bookmarks; you can choose to display bookmarks in the Word Options dialog box.)

    The workaround is to recreate the cross-references immediately after you have noticed the problem. (Alternatively, you can redefine bookmarks, but it's a bit convoluted and, it seems, less predictable in recent versions of Word.)

    To avoid the problem in the first place, avoid pressing Enter (or adding text) at the beginning of a bookmarked/cross-referenced paragraph. Instead, do so at the end of the preceding paragraph instead.


    Stefan Blom, Microsoft Word MVP



    Friday, January 18, 2013 12:38 PM
  • Thanks for the advice.  Unfortunately I have tried your suggestion and it does not solve my problem.  What appears to be happening now is when I update the fields, word inserts a paragraph break immediately before the cross reference and any text before the cross reference is turned into a caption.  
    Friday, January 18, 2013 9:43 PM
  • For Mac Word I would try the following groups:
    http://answers.microsoft.com/en-us/mac/forum/macword

    and specificlly for Mac Word 2008, 

    http://answers.microsoft.com/en-us/mac/forum/macoffice2008-macword


    Peter Jamieson

    Friday, January 18, 2013 10:15 PM
  • Thanks for the advice.  Unfortunately I have tried your suggestion and it does not solve my problem.  What appears to be happening now is when I update the fields, word inserts a paragraph break immediately before the cross reference and any text before the cross reference is turned into a caption.

             

    You haven't explained what you have tried, specifically. Recreating the references should definitely work.

    But, as Peter suggests in his reply, asking in a MacWord forum is probably the best anyway.


    Stefan Blom, Microsoft Word MVP

    Friday, January 18, 2013 11:29 PM