locked
CRM 2013 - Error while using addCustomView : savedquery With Id = 00000000-0000-0000-0000-000000000000 Does Not Exist RRS feed

  • Question

  • Hello,

    While I am using Xrm.Page.getControl(args).addCustomView it was working well in CRM 2011 but when I switched (migrated) to CRM 2013 I got the following Error when the lookup dialog opens:

    Record Is Unavailable
    The requested record was not found or you do not have sufficient permissions to view it.

    And when I check the error details I found

    savedquery With Id = 00000000-0000-0000-0000-000000000000 Does Not Exist

    Any idea how to solve this?

    Wednesday, February 19, 2014 6:39 AM

All replies

  • Hi,

    Please check following link, to add custom views in ms crm 2013.

    http://community.dynamics.com/crm/b/magnetismsolutionscrmblog/archive/2013/09/30/crm-2013-javascript-lookup-filtering-using-addcustomfilter.aspx


    Hope this helps. If you get answer of your question, please mark the response as an answer and vote as helpful !!!
    Vikram Singh. !!!  My Blog

    Wednesday, February 19, 2014 6:50 AM
  • pass parameters like

    "requiredattendees","2","00000000-0000-0000-00AA-000010001003"

    "Field Schema Name","EntityTypeCode","viewID"

    Note: uncheck the "pass execution as pareameter"

    or u can edit ur customization.xml file and change the value "00000000-0000-0000-0000-000000000000" to your view ID

    Note: you can copy your view id by opening your saved query from url


    Thanks in Advance Siva


    • Edited by samcrm Wednesday, February 19, 2014 7:53 AM
    Wednesday, February 19, 2014 7:47 AM
  • Hi, did u find a solution for this? Thanks
    Friday, September 5, 2014 8:22 AM
  • Thanks for that, I'm trying to implement it, however can't complete the call to

    filterAddExistingContact(gridTypeCode, gridControl, primaryEntity) 

    I'm sending the lookupName in gridControl and 9 (Team type code) in gridTypeCode.

    How did u implement this call? Thanks again.

    Tuesday, September 9, 2014 1:26 PM
  • Did you find how to fix it? I get the same error. Spent a lot of time but nothing helps. And this error occurs only for Team entity (CRM 2013\2015). 
    Friday, September 4, 2015 12:28 PM
  • It's a MS bug, fix might be included in May update for CRM 2015.
    Monday, September 7, 2015 8:06 AM