locked
CRM 2011 Outlook "The server address (URL) is not valid." RRS feed

  • Question

  • I've read numerous other threads on this issue, but none seem to be able to help.

    I've got Dynamics CRM 2011 running on a virtualized Server 2K8R2 system.  I can connect perfectly (from our LAN or from an external connection) using http://my.domain.com:5555 which opens CRM just fine in IE.  However, when installed into Outlook, I can [Test connection] which returns the proper organization and display name, but when I click [OK], I'm presented with "The server address (URL) is not valid."

    In reading the Crm50ClientConfig.log file, I'm finding the error is:

    Error|Exception|Metadata contains a reference that cannot be resolved: 'http://myservername:5555/DTS/XRMServices/2011/Organization.svc?wsdl' at System.ServiceModel.Description.MetadataExchangeClient.MetadataRetriever(Timeouthelper timeoutHelper)

    Error|Exception|The remote name could not be resolved: 'myservername' at System.Net.HttpWebRequest.GetResponse().

    Note that 'myservername' is the Netbios (internally accessible) name of the server, not a web-accessible FQDN.  Why is it trying to find my server by its internal name here, rather than the external FQDN?  Is there somewhere this needs to be configured?

    Any assistance would be greatly appreciated.  Right now, our users can see CRM using IE but cannot integrate it into Outlook.

    Thanks.


    -Dan
    Friday, March 25, 2011 5:45 AM

All replies

  • Any assistance would be greatly appreciated.  Right now, our users can see CRM using IE but cannot integrate it into Outlook.

    Thanks.


    -Dan

    Wow, 75 views and not one nibble.  Is this that unusual an issue?  In searching the forums it appeared the "Server address (URL) is not valid." issue was pretty prevalent.

    -Dan


    -Dan
    Monday, March 28, 2011 3:37 PM
  • Hi Dan,

     

    I think you need to use Discovery Service URL as The Server Address(URL) for Outlook configuration.

    Ex: dev.contoso.com


    Khaja Mohiddin
    Monday, March 28, 2011 4:01 PM
  • I'm having the same problem.

     

    DNeuwir, are you useing ADFS with Cliams Base Authentication and Internet Facing Deployment? 

     

    I'm not and I'm not sure if that is the problem. Without using ADFS there is no Discovery Service URL.

     

    Anyone else having the same problem? Solution?

     

     


    Gerhard Peters Interaction Versa Inc. gerhard.peters@iversa.ca
    Sunday, April 3, 2011 7:41 PM
  • I'm having the same issue - i have several CRM online instances.  What's bizzare is that the error comes up AFTER presenting the list of organizations.
    Sunday, April 3, 2011 10:08 PM
  • Inga,

    So you are using the hosted (cloud) CRM 2011 solution? So far I have not found anything to solve the problem. When searching on google it seems like many users are having the same problem.


    Gerhard Peters Interaction Versa Inc. gerhard.peters@iversa.ca
    Sunday, April 3, 2011 10:36 PM
  • I have the same problem.  On-premisis install.  The URL is good.  IT works.  The CRM 2011 for Outlook Configuration Wizard fails AFTER it pulls the organization.  I'm unable to find a resolution.  Fully updated server and Windows 7 w/ Outlook client.
    Wednesday, April 6, 2011 4:30 PM
  • I figured my problem out!   I enabled Anonymous authentication on the CRM site. 

    Open IIS Manager running CRM.  Go to the Microsoft Dynamics CRM site --> Authentication.  Enable  Anonymous authentication.    The CRM Wizard completed.   Mail is flowing!

    Anon auth was enabled by CRM install default.  I had disabled it for tighter security. 

    • Proposed as answer by Steve Baines Tuesday, November 1, 2011 1:57 PM
    Wednesday, April 6, 2011 4:48 PM
  • On our server Anonymous authentication is enabled and it still does not work
    Gerhard Peters Interaction Versa Inc. gerhard.peters@iversa.ca
    • Proposed as answer by sabakux Thursday, September 20, 2012 1:37 PM
    Wednesday, April 6, 2011 5:55 PM
  • Could you please check that the settings for http port in Deployment Manager for CRM match the binding settings in IIS Manager.

    1. Go to CRM server and open IIS manager and check bindings for Microsoft Dynamics CRM website. Remember which port is specified for http

    2. Now open Deployment Manager from Start -> All Programs -> Microsoft Dynamics CRM on the same machine

    3. In Deployment Manager right click on Microsoft Dynamics CRM node and select Web Addresses tab

    4. Make sure that ports specified in deployment manager match the ones in IIS manager. Run IISreset if doing any changes

    Wednesday, April 6, 2011 8:57 PM
  • Thank you Alex for pointing this out. I had the port in CRM Deployment Manager the same as in the IIS binding but I did not have the URL the same.

    In CRM Deployment Manager I was using the default URL e.g. crm:5555 with https as binding and in IIS/Internet Explorer I was using https://crm.domian.com:5555

    Now that I'm using the same URL in CRM Deployment Manager as in Internet Explorer it works like a charm with the Outlook integration.

    I almost became insane over this problem...

     

    I hope this will help others too to solve the problem.   


    Gerhard Peters Interaction Versa Inc. gerhard.peters@iversa.ca
    Wednesday, April 6, 2011 10:12 PM
  • exaclty the same issue here.

    At the deployment manager url´s was simply CRM:80 and changing it to crm.domain.com:80 fixed this.

    Thank You Alex!

     

    Sunday, April 10, 2011 4:06 AM
  • Hi,

    I faced the same problem. But I got it fixed by creating a new outlook profile. Once a new profile is created, the error does not appear anymore.

     

    Theara

    Tuesday, May 31, 2011 11:42 AM
  • Alex

    How should I go about adding the URL in an Network Load Balancing scenario?

    I have two nodes; crm01a and crm01b

    these are network load balanced into crm01

     

    I have tried;

        setting the bindings on each to their own node addresses - this does not work

        setting both their own node address and the NLB address - does not work

        setting only the NLB address - I receive "Server URL address is not valid"

     

    Any help please?

     

     

     

    Wednesday, June 1, 2011 8:24 PM
  • csamuel,

    This is an educated guess since I have no NLB to test on.  However, it should give some things to try while waiting for a more authoritative answer.

    Assuming that crm01 is in the contoso.com domain, set all 4 web addresses listed in the Microsoft Dynamics CRM properties Web Addresses tab to "crm01.contoso.com:80" (or 443 if you are using SSL).  Do this on both crm01a and crm01b.

    After making these changes, perform an iisreset on each server.

    On the client machine, run nslookup from a command prompt.  In there, type crm01.contoso.com and hit enter.  Make sure that the default server returns an address for this machine.

    As long as the nslookup works, the URL should be considered valid.  In the outlook client setup dialog, use http(s)://crm01.contoso.com as the address and test connection.  If it is OK, try to move forward.

    If that does not work, check this article http://technet.microsoft.com/en-us/library/gg554880.aspx to find the log file and see what the error it is returning says.  This file stores all attempts and is in time order, so scroll to the bottom to find the most recent error.

    HTH

    • Proposed as answer by Stefan Näsman Tuesday, January 17, 2012 9:04 AM
    Friday, June 3, 2011 7:50 PM
  • Thanks Prof your advice fixed the issue.

     

    My Outlook CRM Clients can connect to CRM server.

     

     

    When installing the Network Load Balancing for CRM Server - the installation recognises that NLB is in use, but it does not change the Server URL to the Virtual address. Microsoft did not build in this feature to specify the NLB URL address during installation.

     

    The issue was solved by opening CRM 2011 Deployment Manager,

    Right-click on 'Microsoft Dynamics CRM'

    Click the 'Web address' tab

    Amend the URL in the text boxes to the virtual NLB address (as per the Profs advice).

    I did not need to amend the IIS bindings to explicitly point to the owning node address. My current bindings reflect as "http  <blank for host name> port_no *"

    Samuel

    • Proposed as answer by JaroJ Sunday, February 19, 2012 8:52 PM
    Wednesday, June 8, 2011 9:12 AM
  • I had a similar issue where I found this in the log:

    19:34:40|  Error| Exception : Metadata contains a reference that cannot be resolved: 'http://http//crm.contoso.local:80/crm/XRMServices/2011/Organization.svc?wsdl'.    at System.ServiceModel.Description.MetadataExchangeClient.MetadataRetriever.Retrieve(TimeoutHelper timeoutHelper)

    The Deployment Manager lets you prefix the entries on the "Web Address" tab with http or http even though it's clear that's being selected above.  Don't!

    It seems obvious now - but I did it at the time, the dialog box let me, and I spent an hour scratching my head...

    • Proposed as answer by JaroJ Sunday, February 19, 2012 8:52 PM
    Friday, June 17, 2011 6:39 PM
  • worked for me too!
    Tuesday, November 1, 2011 1:57 PM
  • I had this problem. What resolved it for me was adding the proper DNS suffixes for my organization manually!! These were supposed to be applied by group policy but for some reason were not.

    Control Panel --> Network and Internet --> Network Connections --> Select your network adapter --> Properties --> IPv4 --> Advanced --> DNS --> Add DNS suffixes for your organization

    Friday, March 2, 2012 5:07 PM
  • Bingo.  I had to check the the server url in the registry on the crm server and renamed the web address in deployment manager (all of them to be sure).  I had selected https AND included in the address.  Removed the HTTPS:// and added the :443 to the end and then it worked perfectly.

    1 week spent looking for the problem.......

    Thank You

    Friday, April 20, 2012 8:53 PM
  • I found this too, which was really useful. Point 2 fixed mine!

    http://support.microsoft.com/kb/2548802


    Ian Carter

    Click here to go to UNIT4 Business Software.

    Here are my links: Twitter Blog LinkedIn

    Tuesday, October 9, 2012 12:40 PM