locked
Not able to create new user on CRM2011-Onpremise RRS feed

  • Question

  • Dear All,

    It's a fresh installation and we customized almost. But when I am trying to add the new user on CRM2011, i am getting the following error. Also please find the log details. The user already exists on the Active directory on the same domain. Also I found not only one particualar user, all users having same problem except the administrator user that we installed CRM.

    Unable to Change Domain Logon Name

    You do not have necessary permissions to change the domain logon name for this user.

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Access is denied.Detail:
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147187707</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>Access is denied.</Message>
      <Timestamp>2011-06-02T06:44:39.8171875Z</Timestamp>
      <InnerFault i:nil="true" />
      <TraceText i:nil="true" />
    </OrganizationServiceFault>

    Kindly let me know the solution.

    BR,

    NAG.

    Thursday, June 2, 2011 7:05 AM

Answers

  • Couple more things to check and ensure,

    • Check if those users are already in the disabled users by selecting the "Disabled Users" VIEW
    • In your CRM server, go to services.msc and check if the "Workstation" service is set to automatic and started
    • Make sure you have the "AutoGroupManagement" value set to 1 (false) in your registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM)

    Hope, any one of the above will be a possible FIX. (Keep us posted)

     


    Cheers, Francis Edwin

    Follow me on: https://twitter.com/astutecrm

    My Blog: http://astutecrm.wordpress.com/ 

    Thursday, June 2, 2011 11:59 AM

All replies

  • Are you updating an existing user or adding a brand new user?

     

    Are you sure that the user you are trying to add does not already exist in CRM?

     

    Tony

    Thursday, June 2, 2011 8:15 AM
  • Nag,

    I had the same issue and just a restart of the CRM server did the trick for me!

    Thanks


    Cheers, Francis Edwin

    Follow me on: https://twitter.com/astutecrm

    My Blog: http://astutecrm.wordpress.com/ 

    Thursday, June 2, 2011 9:21 AM
  • Hi Tony & Francis,

    Thank you both  for the reply.

    All users are already exists on the Active Directory. But not on CRM. I am trying to create those users on CRM. It's giving the above error which i mentioned earlier.

    Ok Let me restart the server and try again.

    Thanks,

    Nag.

    Thursday, June 2, 2011 10:50 AM
  • Hi again,

    I restarted still the same problem.. :(

    Anything any guessings..

    BR,

    Thursday, June 2, 2011 11:14 AM
  • I have the same problem, restarted the server still the same error.
    Thursday, June 2, 2011 11:54 AM
  • Couple more things to check and ensure,

    • Check if those users are already in the disabled users by selecting the "Disabled Users" VIEW
    • In your CRM server, go to services.msc and check if the "Workstation" service is set to automatic and started
    • Make sure you have the "AutoGroupManagement" value set to 1 (false) in your registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM)

    Hope, any one of the above will be a possible FIX. (Keep us posted)

     


    Cheers, Francis Edwin

    Follow me on: https://twitter.com/astutecrm

    My Blog: http://astutecrm.wordpress.com/ 

    Thursday, June 2, 2011 11:59 AM
  • I checked, no other users disabled

    Workstation service started

    checked registry, it was set as 0, so I changed to 1 and it works!!! thanks a million! :)

    • Proposed as answer by marsinfo Wednesday, March 7, 2012 11:55 AM
    Thursday, June 2, 2011 12:54 PM
  • Lionel,

    Glad it helped, thanks!


    Cheers, Francis Edwin

    Follow me on: https://twitter.com/astutecrm

    My Blog: http://astutecrm.wordpress.com/ 

    Thursday, June 2, 2011 1:01 PM
  • Hi Edwin,

    Thanks. It worked for me also.

    AutoGroupManagement" value set to 0 by default. changed tot to 1.

    BR,

    NAG.

    Friday, June 3, 2011 3:06 PM
  • Second option worked for me.... Thanks a lot.....


    NarSr
    Wednesday, June 15, 2011 11:49 AM
  • Thanks Francis! Changing "AutoGroupManagementOff" value from 0 to 1 fix the issue.
    Wednesday, June 22, 2011 5:24 AM
  • Thanks, The registry change fixed the issue.
    Friday, July 15, 2011 3:47 AM
  • Registry fix worked for me too after first two options were already ok
    Thursday, October 20, 2011 4:09 AM
  • Thank you, the second one is the solution. It saved me a lot of time.

    Monday, December 26, 2011 10:26 PM
  • Thanks Francis! Changing "AutoGroupManagementOff" value from 0 to 1 fix the issue for me too!
    Christopher
    Tuesday, January 3, 2012 5:53 AM
  • Same thing for me too - registry change from "0" to "1" and all is right in the world.

    Server 2008R2, SQL 2008 R2, Dynamics 2011 On Premises...

    Thursday, January 5, 2012 9:03 PM
  • I had the same issue and it worked for me.  Can you explain what AutoGroupManagement does and why setting it to false made this work?  Will this change affect anything else?

    Thanks!


    Christina Bayley | CRM Administrator

    Monday, April 2, 2012 12:50 PM
  • Christina,

     By default, the Auto Group Management functionality is turned on. Microsoft Dynamics CRM automatically adds the appropriate user accounts and the appropriate computer accounts to the required Microsoft Dynamics CRM security groups. If you turn off Auto Group Management, Microsoft Dynamics CRM does not automatically add these accounts. In this case, a domain administrator or a user who has sufficient permissions must add the appropriate user accounts and the appropriate computer accounts to the required groups.

    Hope this clarifies your question!

    Thanks,

    Francis Edwin



    Cheers, Francis Edwin My Blog: http://astutecrm.wordpress.com Twitter: https://twitter.com/astutecrm

    Monday, April 2, 2012 2:48 PM
  • Francis,

    When you say: "Microsoft Dynamics CRM automatically adds the appropriate user accounts and the appropriate computer accounts to the required Microsoft Dynamics CRM security groups.", do you mean the groups in AD?

    I had this issue this morning when I attempted to disable a user.  I have not disabled a user in a while however, I have set up several users over the past few months and I have no issues there.  Based on some other information that I found online, I'm thinking this might have something to do with a database restore that we had to do two months ago on our Production server.  We currently use 4.0 and we are in the process of upgrading to 2011.  About two months ago, while doing the 2011 install on a development server, our current 4.0 production database got hosed (it was my fault).  So, we had to get the backup of the database from the night before and restore it.  We restored it through SQL and not through the deployment manager on the CRM 4.0 app server.  Could this be why I can't disable a user that was created prior to our disaster?

    I suppose I could just turn this off in the registry when I need to disable a user and turn it back on when I'm done?  Since creating new users works but disabling them does not.  Perhaps I'll have to try to disable someone who I recently set up, after our database restore.

    Thanks for your help!

    Christina


    Christina Bayley | CRM Administrator

    Monday, April 2, 2012 4:16 PM
  • Thank you very much. Works for me too. the key in the registry in our machine was AutoGroupManagementOff however, not AutoGroupManagement. Thank you.
    Monday, September 24, 2012 12:32 PM
  • Hi,

    please go through this :

    • Check if those users are already in the disabled users by selecting the "Disabled Users" VIEW
    • In your CRM server, go to services.msc and check if the "Workstation" service is set to automatic and started
    • Make sure you have the "AutoGroupManagement" value set to 1 (false) in your registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM)

    Hope, any one of the above will be a possible FIX. (Keep us posted)

    Thursday, March 21, 2013 7:17 AM
  • thanks for help....and by information... 

    Friday, March 14, 2014 4:28 PM
  • Hi Francis,

    3rd option worked like charm for me, thanks!

    But after reading your explaination, I'm worried, won't the users be added to ReportingGroup/SQLAccessGroup just like it happens in a vanilla instance?

    Will there be issues with Users being added to any of the 5 groups which CRM handles by itself?

    Thanks

    Karishma

    Tuesday, November 18, 2014 5:50 AM
  • I haven't seen anything weird after the change. But i would suggest to change it back to the original value after setting up the user.

    Does that make sense?

    Thanks!
    Francis


    Cheers, Francis Edwin

    Friday, November 21, 2014 10:11 PM
  • This helped in solving the issue. Many thanks.
    Wednesday, April 15, 2015 5:02 PM
  • CRM 2013 - when trying to add new user - unable to change domian logon name You do not hae the necessary permissions to change the domain logon name for this user.

    I've been fighting this for a whole day.

    Change AutoGroupManagementOff in (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM) from 0 to 1.

    I'm trying to find this registry, but my crm 2013 does not have this registry.

    Tuesday, August 18, 2015 9:33 PM