locked
CRM 4 jpeg not included with {Description(E-mail)} in Send Email Workflow RRS feed

  • Question

  • I have setup a queue in CRM 4 to receive incoming emails directed to our helpdesk.
    I have successfully setup a workflow to automatically create a new case for each newly reported incident.
    As part of the workflow I send an email to everybody who works on our helpdesk and include the original email body message using the keyword {Description(E-mail)}
    This works fine except that and jpeg's that were embedded in the original email do not get forwarded.  Only the placeholder appears.  Is there some way to ensure that embedded pictures also appear.

    All help is appreciated.

    TIA,

    Joe Kelly

    Joe
    Saturday, April 18, 2009 2:45 PM

Answers

  • Hi,

    the jpeg from the orginal e-mail will most likely not get forwarded or might be forwarded as an attachement to the e-mail. I believe what Ye Wint referenced was saving the image on a server that has internet access and then referencing it in a link on the forwarded e-mail. Unfortunately, this would take some manual steps which I doubt you want to take since this is an e-mail coming from an external source and is used to create a case.

    I doubt you will be able to acheive what you want without extending the application through some level of customization. 

    If the e-mail is associated to the newly created case, you can check the attachment to see if the jpeg is attached.  If the original e-mail is not associated to the case then maybe you can set the regarding of the e-mail in your workflow to the newly created case.  It is possible that the jpeg will still appear in the e-mail and you can place a message in the description to tell users to view the e-mail for the image or screen shot.

    There are other potential ways to handle this as well, the above is one possibility.
    Best Regards, Donna
    Monday, April 27, 2009 1:33 PM

All replies

  • Hi,

    You Jpeg image is needed to be hosted in Server.
    Cheers!
    Tuesday, April 21, 2009 8:49 AM
  • Thanks for this.

    The jpeg is visible when I look at the case history (open the sent emails in the case history in CRM)

    But the jpeg is not visible when the user receives the email in outlook.

    I don't understand your comment about hosting the jpeg on the server.  How should I do that?
    Joe
    Wednesday, April 22, 2009 11:03 AM
  • Hi,

    the jpeg from the orginal e-mail will most likely not get forwarded or might be forwarded as an attachement to the e-mail. I believe what Ye Wint referenced was saving the image on a server that has internet access and then referencing it in a link on the forwarded e-mail. Unfortunately, this would take some manual steps which I doubt you want to take since this is an e-mail coming from an external source and is used to create a case.

    I doubt you will be able to acheive what you want without extending the application through some level of customization. 

    If the e-mail is associated to the newly created case, you can check the attachment to see if the jpeg is attached.  If the original e-mail is not associated to the case then maybe you can set the regarding of the e-mail in your workflow to the newly created case.  It is possible that the jpeg will still appear in the e-mail and you can place a message in the description to tell users to view the e-mail for the image or screen shot.

    There are other potential ways to handle this as well, the above is one possibility.
    Best Regards, Donna
    Monday, April 27, 2009 1:33 PM
  • Thanks
    Joe
    Thursday, April 30, 2009 9:03 PM
  • You're welcome
    Best Regards, Donna
    Thursday, April 30, 2009 9:55 PM