none
No sound in development environment RRS feed

  • Question

  • Sorry about this silly question...

    Am doing some minor changes to a speech application developed some time ago and now I cannot hear any prompts on my development machine. I am running the speech application on vs2005 and also have vs2008 installed. Have not done any changes since last spring and then it worked fine. Since then I have installed vs2008 and service packs and stuff from windows update.

    The application still runs and the debugging window show the rights prompts but no sound.

    Does anybody know how to get my prompts back or how to troubleshoot this?

    Thanks for your input,
    Markus
    Wednesday, January 7, 2009 1:45 PM

All replies

  • Found some posts on gotspeech.net on others having trouble hearing audio while debugging - this could be due to having several nics configured and speech server settings (Audio settings - Use default audio connection IP), at least when using SIP phones.
    Checked this without results.

    After a restart, I know hear the first prompt while debugging, then it goes silent when the application moves on to the next QA. Am developing on XP sp3 (not sp2). Can this be an issue?

    Thanks for your help,
    Markus

    Thursday, January 8, 2009 7:07 AM
  •  Another confusing clue - after alot of restarts on my local speech server, I can hear more and more prompts. The number of prompts that I can hear seems proportional to the number of restarts...

    Thursday, January 8, 2009 9:19 AM
  • Hi,

    I am facing the same issue with no audio in the voice response window. The same application when deployed on another server, works fine.

    I development environemnt is on Windows Server 2003 Enterprise Edition SP2 and running Microsoft Office Communications Server 2007 Speech Server Developer Edition with the hotfix 963025.

    It also has the following components as part of a standard Speech Server development environment.
    1. Visual Studio 2005 Standard Edition SP1
    2. .NET Framework 3.0 and ASP.NET 2.0
    3. MSXML6
    4. Visual Studio Extensions for Windows Workflow Foundation
    5. Hotfix for Microsoft .NET Framework 2.0 (KB917833) on Microsoft .NET Framework 2.0

    I have tried and verified the following but could not find a resolution to this issue.

    1. Confirmed that there is no Microsoft Loopback adapter for network simulation
    2. There is only one Audio Adapter driver set on this box
    3. OCS console is configured with the default audio connection IP settings. Also verified with other audio connection IPs but that didn't work
    4. Tried rebooting the box but no success

    The prompts from the promptdb works fine (opening the promptsdb from VS2005 and clicking on play)

    I am running into a deadline and any help would highly be appreciated.

    Thanks,
    Dip
    Tuesday, November 17, 2009 3:50 AM
  • Microsoft purposely disabled audio through RDP. I was remotely connected to the environment because of which I was not getting the audio.

    The application worked with a soft phone. Since it works with a phone call just put the app into debug mode in VS then place the call using a real phone instead of the debugger phone interface.

    You can step through a live call using debugger.

    This was answered by Marshal Harisson from gotspeech.net

    Thanks,
    Dip

    Monday, January 4, 2010 6:29 PM