locked
The Wizard was unable to create a volume on the hard drive RRS feed

  • Question

  • When I attempt to add any hard drive to my server storage on my Windows Home Server, I get the following error:

    Hard drive initialization failed.
    The Wizard was unable to create a volume on the hard drive.

    I have tried several USB hard drives and a Hitachi HDS722020ALA330 (2TB drive).  Each time the same error.  I have one drive in the server already (another one of the previously mentioned Hitachi drives).  Each time the dialog box says "formatting drive", then "Adding the hard drive" with a status bar.  It sits at the first point in the bar for a long time (maybe 30 secs).  Then it jumps to the end.  I get a note that the backup service is offline.  Then, the aforementioned error.

    I am able to manually create a partition and format just fine.  I am also able to add the drive as a WHS back up drive with no issues.

    I see no errors in the Windows Event log (other than the entries letting me know the backup service is going offline/online during this procedure).  I see no log files that seem to contain any information about this.

    I am running WHS with power pack 3 and all OS updates installed through Windows update.

    I'm just about at wit's end here.  I would love any pointers.  My experience with WHS was overwhelmingly positive until this issue.
    Wednesday, January 27, 2010 11:29 PM

All replies

  • USB drives are not that recommended for the storage pool (besides as backup drives), since other users have reported problems with such. Maybe you have such issues as well, only earlier than others.
    A 2 TB disk may fail, if the controller driver or the controller firmware cannot handle this. (This has been seen on NVidia controllers at the introduction of 1.5 TB drives.)

    As an idea you could try cleaning the volume first as described in the FAQ How to reinitialize a disk, which is not accepted for the storage pool.

    Best greetings from Germany
    Olaf
    Thursday, January 28, 2010 10:21 PM
    Moderator
  • Thank you for the reply!

    I have tried the recommendations in that FAQ.  Same result, unfortunately.  I've also tried a 500mb SATA drive as well with the same result.  The 2 TB drive I mention above is SATA, and since I'm able to mount the drive, format and assign a drive letter manually, it is not clear to me what WHS is attempting to do that is failing.

    I've also tried the "mountvol /e" trick that I've seen a few people say has worked for them.  Didn't work for me unfortunately.

    I really wish I could get a glimpse at exactly what WHS is trying to do under the hood here.  Is there a log file somewhere that would show some of the internals?
    Friday, January 29, 2010 12:52 AM
  • This sounds indeed strange. May I recommend to register on Microsoft Connect and issue a bugreport, if the following questions cannot help to solve the issue?

    Are there any notes, errors or warnings in the event log?
    Or on the server, if you click Start/Run and open %qlogs% folder, are there any logs created near the time of the attempt to add the disk?
    Do they show related content?
    Is the Bios of the server eventually set to write protect disks or parts of the disks (i.e. boot sector virus protection)?

    Best greetings from Germany
    Olaf

    Friday, January 29, 2010 9:44 PM
    Moderator
  • I am having the same problem with a seagate 1.5tb drive,
    I have two one will mount fine as a back up disk, but I cannot get either of them to add to the storage pool
    tried all the forum suggestions,  diskpart etc
    Saturday, January 30, 2010 1:10 AM
  • There were no errors in the event log (just a few entries about the backup service stopping/starting) and no information in the log files that I could find.  I looked carefully through the BIOS options (it's a Gigabyte EP43-UD3L board) and tried a few drive-related settings.  It didn't help.

    I reinstalled Home Server and installed only the necessities (updated chipset / LAN drivers) and then attempted to add the drive to the backup set before doing anything else.  It worked very well.  My music collection is duplicating as I write this.  Now that all Windows updates have been applied and settings restored, I am very curious to see if I'll be able to add another drive.

    When I originally set up WHS I had used the Microsoft utility to copy the WHS setup from the ISO to a flash drive and had installed WHS from USB.  There was an error late in that installation process.  I forget what it was now, but I had to modify a configuration file manually before the setup would finish.  That very well might be related.

    Anyways - thanks very much for the suggestions.
    Monday, February 8, 2010 1:15 AM
  • When I originally set up WHS I had used the Microsoft utility to copy the WHS setup from the ISO to a flash drive and had installed WHS from USB.
    Out of interest where can this this utility be found?

    Cheers,
    Al
    --
    Monday, February 8, 2010 2:22 AM
  • Maybe here
     
     
    or even MS's own tool
     
     
    even though MS says it is for Win 7 only, there are wide spread reports that it works with WHS also.
     

    --
    ______________
    BullDawg
    Associate Expert
    In God We Trust
    ______________
     
    "Al West" <=?utf-8?B?QWwgV2VzdA==?=> wrote in message news:ff3358dd-c181-43f 0-9808-7a71c85d0c43...
    When I originally set up WHS I had used the Microsoft utility to copy the WHS setup from the ISO to a flash drive and had installed WHS from USB.
    Out of interest where can this this utility be found?

    Cheers,
    Al
    --

    BullDawg
    Monday, February 8, 2010 3:42 AM
  • I've been using the Windows 7 USB DVD Download Tool myself, and it works great most of the time. However, there are some issues with the iso-files. Not sure exactly what is causing it, but some iso files will not work. (Says something about not being a valid iso)
    However, I did rip the whs dvd and tried this, and it seems to work, however I haven't used it to install anything yet.

    Jason, noticed you're running a Gigabyte board. Do you have a floppy drive installed? If not, disable everything in the bios related to the floppy. Also remove the floppy from the boot order. There is something strange with the gigabyte bios and people are having all sort of weird trouble with drive access etc. I couldn't even install whs unless I turned it off.
    Might be worth a try...
    Monday, February 8, 2010 7:18 AM
  • This was the tool I used to load WHS the first time:
    http://store.microsoft. com/Help/ISO-Tool

    Like I said, it worked, but not completely.  The error occured after the Windows 2003 portion of the install...during the part where it layers on WHS.  Just found the error message I received from my browser history around that time:  "System cannot find the path specified."  Pretty sure there was a drive letter hard coded into a config file that was incorrect.  I changed it to the correct drive for my USB and then the install worked from there on out.

    All is working great now.  I'm able to add drives to the backup collection. 
    Tuesday, February 9, 2010 5:39 PM
  • i have de Same thing from de wizard i can not spreak whit myn child on de cam en spreek with de cam al so what most y doe ing
    Thursday, February 11, 2010 11:11 AM
  • Hi, I'm experiencing the exact issue as Jason L. 

    In my case, a 2TB storage pool drive failed, so I removed it successfully, and I added an 2TB external USB hard drive temporarily while my failed drive gets RMA'ed.  When my new 2TB drive arrived, I tried to add it to the storage pool, but I'm getting the "Hard drive initialization failed. The wizard was unable to create a volume on the hard drive."  I ran through the suggestions in the FAQ on how to reinitialize a disk and I also tried the mountvol /e in the command line.  Both didn't help.

    Short of reinstalling WHS, is there anything else I can try?

    Wednesday, June 20, 2012 4:49 AM
  • What happens, if you attach the disk to the internal controller?

    Sometimes its simply the USB controller, chipset or the external case electronics, causing the trouble.

    Or the new disk is DOA ...

    Best greetings from Germany
    Olaf

    Wednesday, June 20, 2012 12:12 PM
    Moderator