locked
Outlook Integration Errors RRS feed

  • Question

  •  

    Sorry for the cross post - not sure I got it in the right area first....

     

    Have installed OCS and got about 15 users up and running using office communicator 2007.

     

    Just one user (me) is having problems integrating with Outlook 2007.

     

    Error message says - "There was a problem connecting to Microsoft Office Outlook. Your Outlook profile is not configured correctly."  It then tells me to contact myself

     

    As far as I can see, my profile is configured correctly, there is only one profile, it is called Outlook (the default name), the mailbox is on a server and has the same permissions as another user who's communicator is working fine.

     

    Have gone through various things with the profile, including deleting and re-creating it. Outlook connects to an Exchange 2003 server. 

     

     

    Any help appreciated

     

    Cheers

    Nick

    Monday, April 2, 2007 8:43 AM

Answers

  • Hi Nick,

    I am checking on whether ESM is a known issue. We created a FAQ about Outlook Integration issues, because it is a known issue.

    Here are some things you can try, if you haven't already:

    • Start Outlook, wait a few minutes and then start Communicator.
    • Check that Outlook is using the default profile.
    • Verify you are using Office Communicator 2007 build 2.6090.0.
    • Verify your Internet Explorer proxy settings are correct for your environment.
    • Try to connect to your Adress Book Server URL's manually. If they are not accessible, then troubleshoot your web services:
      • For example:
        • Try to connect to the URLs from the server.
        • Check for any DNS issues.
        • Check any routing issues.
        • Try resetting IIS.
        • Try restarting the web pages.
    • Verify you are using the same credentials in Outlook as you are in Communicator.
    • Verify your are not using an untrusted certificate in Exchange Server 2007.
    • Delete galcontacts.db located in %userprofile%\Local Settings\Application Data\Microsoft\Communicator On the OCS server open a command prompt. Navigate to <install path>\Server\Core\ and then run ABServer.exe -syncNow
    • In Office Communicator, under Tools>Options,on the bottom part of the Personal tab is the Personal information manager. Verify that the 'Automatically retrieve Out of Office settings from Outlook' and 'Update my status based on calendar data' options have been selected.
    Thursday, May 24, 2007 5:55 PM

All replies

  • Are you using the same credentials on OCS and the Outlook/Exchange?

    It's seams that it cannot match the user on the OCS client with the user of the mailbox

    Wednesday, April 4, 2007 4:27 PM
  • Hi,

     

    yes the same credentials are being used.

     

    Thanks

    Nick

    Thursday, April 5, 2007 9:16 AM
  • Have you gone through the OC2007 Deployment guide? There is a section on Outlook Integration, starting on page 9.

    Monday, April 9, 2007 6:35 AM
  • Hi,

     

    Yes, have gone through the deployment guide - Have also gone through the testing guide (which includes troubleshooting), have switched on all logging, and have run un-install/re-install with verbose installer logging on - None of which has shown any obvious problems or information that in meanigful (there is a lot of data in the install log... nothing stands out as an error in it).

     

    Is there any other level of logging that I can switch on to determine what is failing?

     

    Cheers

    Nick

    Thursday, April 12, 2007 12:27 PM
  • Yes, you can install the resource kit  from the Setup\I386\Setup folder, lcreskit.msi. Once you have installed this, you can then right click the pool and select Start New Debug session. From there you can make various logging selections. You can then view and analyze the logs, or post them here to submit more info.
    Monday, April 16, 2007 6:08 AM
  • Thanks for the help, have installed the res kit.

    Logging for server side activity is OK, but either I'm missing something, or the res kit debug options don't contain anything to allow debugging of problems within Office Communicator?

    As far as I can see, this is a client side problem, not a server problem (unless the integration with Outlook is managed by the server?).

     

    Nick

    Monday, April 23, 2007 7:33 AM
  • It appears this is a fairly common resolution with no solution as of yet. I am having the same issue and my OOF works fine along with autodiscovery. I did fix this AFTER my comm2k7 install.
    Monday, April 23, 2007 8:30 PM
  • In MOC 2007, you can go to Tools->Setup and on the General tab turn on logging and Windows Event logging. Then examine the event viewer. You can also turn on Tracing on the communicator by changing the registry key on the client:

     HKEY_CURRENT_USER\Software\Microsoft\Tracing\uccp\Communicator

    Change the EnableFileTracing value to 1, and this log will be wirtten to C:\Documents and Settings\[User]\Tracing

     

    You can post the logs here for everyone to see for assisting you.

    Thursday, April 26, 2007 11:19 PM
  • Thanks Thom,

     

    I now have lots of logging.

    I might be missing something though, I can't seem to find any references in the logs to the Outlook integration failure, or anything that even looks like it might be related.

    Any ideas where in the logs I should be looking?

     

    Nick

     

     

     

     

    Friday, April 27, 2007 8:52 AM
  • Hi all,

     

    I have the same problem. Standard setup, everything is working, except the integration with Outlook 2007. Every PC with Outlook 2007 has this issue. OC 2007 integrates perfectly with Outlook 2003 in the same environment though.

     

    Is there anybody who has the integration working with Outlook 2007?

     

    Thanks in advance

     

      

    Tuesday, May 1, 2007 8:24 AM
  • Yes, OC 2.0 and Outlook 2007 should work fine together.

     

     

    By chance is the following installed on your system?
    Exchange 2003 System Manager

    Monday, May 7, 2007 6:33 PM
  • As a matter of fact, I do have Exchange 2003 System Manager installed.

    To be honest I  had considered that, but had discounted it because one of my administrators also has it installed without Communicator problems..

     

    Are there any known problems with Exchange System Admin installed on the same box?

     

    Cheers

    Nick

    Tuesday, May 8, 2007 8:22 AM
  • We had this same problem; it was caused by an untrusted (self signed) certificate in Exchange Server 2007 that was created during install. This untrusted certificate also caused warning messages in Outlook when using the Scheduling assistant.

    After we updated the Exchange server certificate to a trusted one, the Outlook Integration error in OC also went away.

     

    -- Maarten

    Wednesday, May 9, 2007 10:31 PM
  • I have a valid cert innstalled but i am still recieveing the prompts when opening outlook, etc. How do i remove those?
    Thursday, May 10, 2007 1:50 PM
  • Hi Nick,

    I am checking on whether ESM is a known issue. We created a FAQ about Outlook Integration issues, because it is a known issue.

    Here are some things you can try, if you haven't already:

    • Start Outlook, wait a few minutes and then start Communicator.
    • Check that Outlook is using the default profile.
    • Verify you are using Office Communicator 2007 build 2.6090.0.
    • Verify your Internet Explorer proxy settings are correct for your environment.
    • Try to connect to your Adress Book Server URL's manually. If they are not accessible, then troubleshoot your web services:
      • For example:
        • Try to connect to the URLs from the server.
        • Check for any DNS issues.
        • Check any routing issues.
        • Try resetting IIS.
        • Try restarting the web pages.
    • Verify you are using the same credentials in Outlook as you are in Communicator.
    • Verify your are not using an untrusted certificate in Exchange Server 2007.
    • Delete galcontacts.db located in %userprofile%\Local Settings\Application Data\Microsoft\Communicator On the OCS server open a command prompt. Navigate to <install path>\Server\Core\ and then run ABServer.exe -syncNow
    • In Office Communicator, under Tools>Options,on the bottom part of the Personal tab is the Personal information manager. Verify that the 'Automatically retrieve Out of Office settings from Outlook' and 'Update my status based on calendar data' options have been selected.
    Thursday, May 24, 2007 5:55 PM
  • Thanks for the help Thom, have tried all the above and still getting the same issue.

     

    • Start Outlook, wait a few minutes and then start Communicator.  Tried this - no joy.
    • Check that Outlook is using the default profile. Only have one profile, Called 'Outlook'
    • Verify you are using Office Communicator 2007 build 2.6090.0. Yep, I'm using that build
    • Verify your Internet Explorer proxy settings are correct for your environment. I can browse the internet just fine. Our proxy server (ISA) is set to require authentication, and also uses Websense for content management. Should this make any difference? My email system is internal and local, and I would not expect any communication to have to travel across my WAN and back to talk to a server in the next room.
    • Try to connect to your Adress Book Server URL's manually. If they are not accessible, then troubleshoot your web services:Address book URL's are all accessible 
      • For example:
        • Try to connect to the URLs from the server.
        • Check for any DNS issues.
        • Check any routing issues.
        • Try resetting IIS.
        • Try restarting the web pages.
    • Verify you are using the same credentials in Outlook as you are in Communicator.Am using the same credentials 
    • Verify your are not using an untrusted certificate in Exchange Server 2007. We are using EXCH2003, not 2007, but no untrusted certs should be anywhere near it.
    • Delete galcontacts.db located in %userprofile%\Local Settings\Application Data\Microsoft\Communicator On the OCS server open a command prompt. Navigate to <install path>\Server\Core\ and then run ABServer.exe -syncNow Tried this, still getting problem 
    • In Office Communicator, under Tools>Options,on the bottom part of the Personal tab is the Personal information manager. Verify that the 'Automatically retrieve Out of Office settings from Outlook' and 'Update my status based on calendar data' options have been selected. These options always have been set.

    The error message within Communicator is saying that my Outlook profile is not configured correctly - does this make resolution any easier?

     

    Thanks

    Nick

    Friday, May 25, 2007 8:39 AM
  • I am sorry none of those steps helped with your issue. This is a known issue, and my best suggestions is to keep checking the forums for answers. We will keep posting additional fixes to the FAQ about this.
    Monday, June 4, 2007 6:57 PM
  • Have there been any updates to this issue.  I've had Exchange 2007 and Outlook 2007 up and working fine for a few months.

     

    Last night, I just installed OCS 2007 Standard Edition. Now when I log into MOC 2007 I receive the Outlook integration issue.  At first I was prompted with 2 errors, so I installed the Outlook hotfix (http://support.microsoft.com/kb/936864/en-us ).  One of the errors went away.

     

    Now I am still receiving the following error:

    "There was a problem connecting to Microsoft Office Outlook. The e-mail address used in your default Outlook profile is different from the sign-in address used in Communicator.  Change your default Outlook profile to match the sign-in address you are using in Communicator, and then sign out and sign back in to Communicator."

     

     

    The default Outlook profile is configured for my account.  The only thing that I can think of is my default smtp address is nickname@servusinc.com (secondary first_lastname@inside.servusinc.com), but my Communicator sign-in address is first_lastname@inside.servusinc.com.

     

    Thursday, November 1, 2007 5:38 AM
  • I'm having exactly the same issue, except the smtp address is the same.

    Only thing is that OCS has been deployed in a different AD forest for reasons not worth going into.  LCS has worked fine in this way, but OCS just won't integrate with Outlook.

    Tuesday, November 27, 2007 5:12 AM
  • I have the same issue for three exchange admins that both have ESM installed. One admin uninstalled ESM and he can now use OC2007 just fine.  The other two still have ESM, when they log into another PC with no ESM they have the same error that follows their account even to PC's that are known to not have any OC2007 integration error issues.  Of course, all are using their primary SMTP to sign into OC2007. 

     

    Here is the error that shows up in the OC2007 Logs:

    SIP/2.0 403 Location profile only available when UC enabled

     

    The primary accounts are SIP enabled, secondary accounts are not SIP enabled.

    Tuesday, November 27, 2007 7:10 PM
  • I found upgrading my Outlook 2003 SP1 to SP3 did the trick. Definitely a client related problem.

     

    Thursday, December 13, 2007 3:49 PM
  • I was having the same issue that everyone here was having, but none of the solutions worked. However, I just ran across this solution and it fixed the issue immediately.

     

    It appears to be a MAPI dll issue that can be fixed by doing the following:

     

    1)  Run FixMAPI.exe from a command prompt

    2)  Reboot

     

    My config:

    Exchange 2003 System Manager

    Office 2007 SP1

    Communicator 2007 build 2.0.6362.36

     

    http://groups.google.com.ua/group/microsoft.public.livecomm.general/browse_thread/thread/2ce123598a0d571c/894fd59814d8d3db?lnk=raot

     

    Wednesday, December 19, 2007 3:46 PM
  •  DaveRowe26 wrote:

    Have there been any updates to this issue.  I've had Exchange 2007 and Outlook 2007 up and working fine for a few months.

     

    Last night, I just installed OCS 2007 Standard Edition. Now when I log into MOC 2007 I receive the Outlook integration issue.  At first I was prompted with 2 errors, so I installed the Outlook hotfix (http://support.microsoft.com/kb/936864/en-us ).  One of the errors went away.

     

    Now I am still receiving the following error:

    "There was a problem connecting to Microsoft Office Outlook. The e-mail address used in your default Outlook profile is different from the sign-in address used in Communicator.  Change your default Outlook profile to match the sign-in address you are using in Communicator, and then sign out and sign back in to Communicator."

     

     

    The default Outlook profile is configured for my account.  The only thing that I can think of is my default smtp address is nickname@servusinc.com (secondary first_lastname@inside.servusinc.com), but my Communicator sign-in address is first_lastname@inside.servusinc.com.

     

     

    Dave I am also having the exact same issue as you. Did you ever resolve this? I also have different smtp addresses.

     

    TIA!

    Friday, January 4, 2008 3:53 PM
  • I have a similar situation - my SIP URI domain is different than the primary SMTP.

     

    I had 2 integration errors - I installed the hotfix recommended by one of them, but I still had the "problem connecting" error. I then realized that there were multiple outlook profiles on the test machine. I removed all but the one I intended to use, and the second integration error disappeared, but I still don't get outlook integration. I think it may be because the SIP URI and SMTP addresses are different.

     

    Can someone tell me what the rules are for the integration to work? I can't seem to find where all of these specifics (only one outlook profile, SMTP same as SIP URI, etc...) documented.

     

    Thx!

     

    Saturday, January 5, 2008 9:18 PM
  • Try 

    Start -> Run -> FIXMAPI

    Retart outlook and OC 2007.

    It will be fix!

    Sunday, May 11, 2008 2:07 PM
  • I have this issue on all Windows Vista Clients with Office 2007. Is there something different on Vista? Every XP Client is running smooth without any warnings.
     
    Tuesday, June 24, 2008 8:53 AM
  •  

    To all that are searching for answers to this issue, try this first before any other fix.  I have tried every single other posted fix and this ended up be the one that fixed it for me and my colleague.

     

    Now if I could just get the conf add-in working.......

    Thursday, August 7, 2008 5:41 PM
  • I tried the fixmapi.exe and it didn't work. I am running the Communicator and Outlook clients on a server with Exchange/OCS/Sharepoint.

    Any new ideas?
    Monday, December 15, 2008 7:41 PM
  • i tried the all of your advice but they didn't work and i have error in integeration with outlook

    i don't use Exchenge server for email service  and i use p0p3 services

    may be my problem for it!!!

    plz help me
    • Edited by UCDEMO Wednesday, April 15, 2009 7:31 PM edit
    Wednesday, April 15, 2009 7:30 PM
  • I've tried all these solutions with no results.  I've tried numerous others as well, all with the same error:

    403 Location profile only available when UC enabled

    If I turn off "Update my presence based on my Outlook calendar information" in Communicator the error goes away.  However I'd kind of like to use this option.  Due to the limitations of our business model, unified messaging is not setup in exchange and cannot be setup.  Is this message as simple as saying my location is not available unless Unified Communications (UC) is enabled for a user?  If so, it might be kind of nice to make this information available as I have not seen any reference to it in any white papers or installation guides.

    thanks


    Wednesday, April 22, 2009 9:07 PM
  • Hi All,

    I may have a solution for you.  First, I will describe the error so that you can identif if this is your issue or not.  We were getting the same "Outlook Integration Error" for communicator.  However, we were only getting it on specific machines.  The same user could log on to a different machine and not get the error.  Basically, we did the following (make sure you are signed out of both Outlook and Communicator before performing these steps):

    1. Right click on Outlook and click properties
    2. Click the Show Profiles button.
    3. Highlight each profile (including Default) and remove.  Ensure there are no profiles left on the machine.
    4. Restart outlook and follow the wizard, create a profile called Default.

    I will be running through these steps again on additional PCs.  If there are steps I have missed in this post I will update.  I should have an update (if needed) in about an hour or so.

    Cheers
    Monday, April 27, 2009 3:19 PM
  • Update: The steps above did not resolve the issue on one of our workstations. For this workstation we needed to do something extra. We needed to un install exchange manager before performing the steps and needs to disable the proxy in IE prior to launching Communicaator for the first time. The second step is simply because we are running in a pilot, and do not have the OCS server set up as one of our proxy bypass rules in IE. Cheers
    Monday, April 27, 2009 10:04 PM
  • Y did all that i see in this forum, and for me the solution was the next:

    1. Right click on Outlook and click properties (Or in panel de control panel start mail
    2. Click the Show Profiles button.
    3. The profile MUST be named "default" If you have another name, you can copy and put "default"  in the new default name. The you can delete the other profile.

    I'M MOC R2 3.5.6907.37. The Outlook Version is 14.0.4006.1110 (32 bits, the 64 bits still don't integrate with MOC)
    Emerson Gonzalez T. http://www.isahowto.org
    Sunday, September 13, 2009 8:49 PM