none
Deployment problem with Xamarin, VS2017 and Android - compile warnings on targetframework and black screen in emulator RRS feed

  • Question

  • Hi!

    I have just updated my VS2017 installation to the latest (5th of December 2017).

    I created a cross-platform App (Xamarin.Forms) in C#. On screen 2 I select "Master Detail".

    I get the following warnings when compiling and a black screen when trying to debug the Android version.

    1>------ Build started: Project: TestApp.Android, Configuration: Debug Any CPU ------
    2>------ Skipped Build: Project: TestApp.iOS, Configuration: Debug iPhone ------
    2>Project not selected to build for this solution configuration 
    3>------ Skipped Build: Project: TestApp.UWP, Configuration: Debug x86 ------
    3>Project not selected to build for this solution configuration 
    1>  TestApp.Android -> C:\Utilities\Apps\TestApp\TestApp\TestApp.Android\bin\Debug\TestApp.Android.dll
    1>  No way to resolve conflict between "mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" and "mscorlib, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e". Choosing "mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" arbitrarily.
    1>C:\Utilities\Apps\TestApp\TestApp\TestApp.Android\TestApp.Android.csproj : warning XA0105: The $(TargetFrameworkVersion) for FormsViewGroup.dll (vv8.0) is greater than the $(TargetFrameworkVersion) for your project (v7.1). You need to increase the $(TargetFrameworkVersion) for your project.
    1>C:\Utilities\Apps\TestApp\TestApp\TestApp.Android\TestApp.Android.csproj : warning XA0105: The $(TargetFrameworkVersion) for Xamarin.Forms.Platform.Android.dll (vv8.0) is greater than the $(TargetFrameworkVersion) for your project (v7.1). You need to increase the $(TargetFrameworkVersion) for your project.
    1>C:\Utilities\Apps\TestApp\TestApp\TestApp.Android\TestApp.Android.csproj : warning XA0105: The $(TargetFrameworkVersion) for Xamarin.Forms.Platform.dll (vv8.0) is greater than the $(TargetFrameworkVersion) for your project (v7.1). You need to increase the $(TargetFrameworkVersion) for your project.
    ========== Build: 1 succeeded, 0 failed, 0 up-to-date, 2 skipped ==========


    Now, I am not able to select TargetFramework 8.0 on the properties. V7.1 is the newest version - I have scrutinized the list of packages on the VS2017 installer, but I've not been able find the Google Android API level 26, which I think is the 8.0 version (right?).

    Please advice how to resolve this.

    Best regards,

    Rasmus
    Thursday, December 7, 2017 5:22 PM

All replies

  • I have the same problem!
    Saturday, December 9, 2017 6:38 PM
  • Hi Rasmus Ursem,

    Thank you for posting here.

    According to your description is more related to Xamarin, please post your question in Xamarin forum for suitable support.

    The CLR Forum discuss and ask questions about .NET Framework Base Classes (BCL) such as Collections, I/O, Regigistry, Globalization, Reflection. Also discuss all the other Microsoft libraries that are built on or extend the .NET Framework, including Managed Extensibility Framework (MEF), Charting Controls, CardSpace, Windows Identity Foundation (WIF), Point of Sale (POS), Transactions. 

    Best Regards,

    Wendy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 12, 2017 6:38 AM
  • I too have the same problem

    Ramakrishna

    Thursday, December 14, 2017 5:22 AM