none
Synctoy installs but won't run RRS feed

  • Question

  • As soon as I click on the exe file to run Synctoy 2, I get the error message saying it won't run and that a problem has been encountered and Synctoy needs to close..

     

    I believe the .net framework program required is present but not absolutely certain. Version 3 shows up in my program list in add/remove pgms so my guess is that it is there and functioning.

     

     Anyone else encounter this and successfully worked around it?

     

    Background..I wanted to do a backup today after a lapse of a few months and discovered that v1  got the same error described above.  I found the update, downloaded, installed the package. Same error.

     

    Running XP, sp3

    Thursday, November 6, 2008 12:08 AM

Answers

  • SyncToy 2.0 has the following dependencies:

    • .NET Framework v2.0 or higher
    • Microsoft Sync Framework Runtime v1.0
    • Microsoft Sync Framework Services v1.0

    Both components of Microsoft Sync Framework are installed by SyncToy installer.  If you say you have .NET framework 3.0, my guess is that somehow you must have uninstalled one of the Sync Framework components listed above.  Re-installing SyncToy v2.0 will fix this problem.

     

    Maria del Mar Alvarez Rohena - MSFT

    Saturday, November 15, 2008 12:56 AM

All replies

  •  

    have you ever tried to reinstall .NET Framework ?

     

    Thanks,

    Baoke

    Friday, November 14, 2008 6:32 AM
  • Baoke: that's an excellent suggestion, one that my instinct should have told me to try.  But I needed a reliable backup quickly so I reluctantly abandoned  S'toy and went to Syncback (by 2brightsparks) and it worked well. I'm sure a Framework reinstall will be helpful for other things so your reminder is much appreciated

    Friday, November 14, 2008 6:35 PM
  • SyncToy 2.0 has the following dependencies:

    • .NET Framework v2.0 or higher
    • Microsoft Sync Framework Runtime v1.0
    • Microsoft Sync Framework Services v1.0

    Both components of Microsoft Sync Framework are installed by SyncToy installer.  If you say you have .NET framework 3.0, my guess is that somehow you must have uninstalled one of the Sync Framework components listed above.  Re-installing SyncToy v2.0 will fix this problem.

     

    Maria del Mar Alvarez Rohena - MSFT

    Saturday, November 15, 2008 12:56 AM
  • I'm running XP SP3.  I've had this problem since I installed Symantec Internet Security Suite.  Also couldn't download and install updates for many programs, couldn't install TurboTax 2010, etc. 

    I uninstalled and reinstalled all the .NET Frameworks.  I unregistered and re-registered Windows Installer.  I followed several other recommended approaches without success.  I was about to reformat my hard drive and reinstall everything.  Fortunately (cause it wouldn't have fixed the problem), I stumbled across another solution . . .

    The solution for me was to stop Process Monitor.  Process Monitor is presumably a valuable tool for XP.  But you can do without it for an event or two, like installing a program or upgrading a program. 

    You stop Process Monitor by going to Control Panel, selecting Administrative Tools, then Services.  Double-clicking Services opens a window that lists a bunch of services, provides a "description", Status, Startup Type, and Log on As . . .

    Scroll down to Process Monitor, right click on that line, and select "Stop".  After running Sync Toy, you can turn it back on.

    Sunday, May 15, 2011 2:36 AM