Change Log On for sql server for CRM 4.0 RRS feed

  • Question

  • Hi,
    What are the steps that I need to take if I were to change the log on under which sql server runs?
    On my CRM 4.0 virtual machine, it was running under the administrator account, but for various reasons, I need to change it to a different user. I created an active directory user and changed the following services to run under new user. Everythign seems to work fine, except reporting services.

    SQL Server Agent
    SQL Server Integration Services 10.0
    SQL Server Reporting Services (MSSQLSERVER)

    Thanks in advance, 
    Tuesday, August 11, 2009 12:40 AM


All replies

  • Yes, reporting services will not like that change.  You will need to go into the Report Server Configuration Manager and make the change there.  Chances are you are going to have to delete your virtual report directory in IIS and then go to the Configuration Manager and re-create and use the new credentials.  This should work for you.  You can try to make the change without deleting the directory but you will probably get an error.  If you receive an error, bing it and you will see many posts on deleting the virtual report directories from IIS

    Best Regards, Donna
    Tuesday, August 11, 2009 1:10 AM
  • Thanks Donna for your reply.
    When I go to IIS, go to the site Microsoft Dynamics CRM and click on View Virtual Directories, there's nothing under it.
    I opened up Reporting services configuration manager, under service account, changed the account to the new user. It was successful.
    Under Database, I clicked "Change Credentials" and changed the user, it was successful.
    Now when I try to run the report, I get two errors in event log:
    "One or more data sources is missing credentials".
    "Report Server (MSSQLSERVER) cannot load the TERADATA extension".

    What am I missing?
    Tuesday, August 11, 2009 5:27 PM
  • I am not sure at this point because I don't follow the steps you have listed:

    When I go to IIS, go to the site Microsoft Dynamics CRM and click on View Virtual Directories

    I am going to assume you were able to change both Windows Service Identity and Web Service Identity in the Report Server Configuration Manager and that you have all Green Checks beside all the items in the Report Server Configuration Manager?

    Are you sure you had Reports working before this change?  I think it is very odd that the Report Server Configuration Manager didn't complain when you tried to change the Windows or Web Service Identity.
    Best Regards, Donna
    Tuesday, August 11, 2009 6:15 PM
  • Hi Donna,
    This is what I did:
    I went to Reporting services configuration Manager.

    1. Under Service Account, for the Report Server Service Account, I changed the account and password under "Use Another Account" (this option was selected with a different account before).
    2. Under Database, for Current Report Server Database Credential, I clicked on Change Credentials and followed the steps to change the user.

    I dont see any Green Checks anywhere in the Report Server Configuration Manager. And I still get the two errors I mentioned earlier today.

    I probably should have mentioned, my VM is using SQL server 2008.

    I also went to services, changed the user credentials under Logon and restarted the services for SQL Server Reporting Services (MSSQLSERVER).

    Yes, the reports were working before this change.

    Thanks again for your help.
    Tuesday, August 11, 2009 7:10 PM
  • Peruse these links and see if the information helps. 

    Error message when you run a report in Microsoft Dynamics CRM 4.0: "The report cannot be displayed"




    Other than the above, I don't have any other suggestions.  It seems that you have some potentially unique environment elements that are going to require a hands-on approach to resolve.

    Best Regards, Donna
    Tuesday, August 11, 2009 8:18 PM
  • you can see my blog
    Eirc's Yang(杭州-天天) cnblog:http://www.cnblogs.com/ericqyang/ MSN:yqing630@hotmail.com
    Friday, August 14, 2009 7:23 AM