none
Can't Exclude Folders/Subfolders RRS feed

  • Question

  •  

    Hello all, and thanks for making such a handy little tool.

     

    Perhapse I'm ignorant, as this is my first time playing with SyncToy.  However, after I setup an action to sync between a local drive and a flash drive, the "Preview" function is showing me unexpected results.  Because I want to sync MOST of the folders between the two, but not all of them, I used the "Select Subfolder" link to de-select some folders and subfolders.  Nonetheless, the "Preview" shows a full sync, ignoring the excluded folders selections.  I've confirmed my folder de-selections.

     

    Any thoughts?

     

    -Oscilated

    Thursday, October 9, 2008 8:09 PM

Answers

  • Yes, SyncToy 2.0 x64.

     

    I've rebooted, re-opened SyncToy, navigated to change options page and verified my de-selections.  Preview still shows unexpected results (full sync).

     

    I'm running this on a fairly large root folder with many includes and excludes.

     

    To help diagnose, I'll keep the same sync pairs, but exclude ALL subfolders.  Then I'll slowly, one at a time, add a folder to see if I can work around this.

     

    Thanks for the suggestions thus far,

     

    -Oscilated

     

    Friday, October 10, 2008 4:27 PM

All replies

  • Do you use SyncToy 2.0? It sounds wired, please close SyncToy then re-open it, then go into change action page to checke and make sure the subfolders you want them to be excluded are de-selected. Then try to preview this folder pair to find if this happens again?

     

     

    Thanks

    Ping

    Friday, October 10, 2008 5:49 AM
  • Yes, SyncToy 2.0 x64.

     

    I've rebooted, re-opened SyncToy, navigated to change options page and verified my de-selections.  Preview still shows unexpected results (full sync).

     

    I'm running this on a fairly large root folder with many includes and excludes.

     

    To help diagnose, I'll keep the same sync pairs, but exclude ALL subfolders.  Then I'll slowly, one at a time, add a folder to see if I can work around this.

     

    Thanks for the suggestions thus far,

     

    -Oscilated

     

    Friday, October 10, 2008 4:27 PM
  • Seems to be working now.  Deleted all of SyncToy's .dat files on the flash drive then initiated a preview.  However, a new issue has popped up.

     

    SyncToy is NOT showing "Last Modified" dates/times for many of the files on my flash drive.  I assume this is why it's still wanting to sync some files, even though the files are definitely in sync.  The flash drive is 32Gb and using NTFS.

     

    To work through this, I'm going to manually sync, one folder at a time, those files, and after each folder's manual sync,  initiate a sync with SyncToy on that single folder.

     

    This looks to be pretty promising.  And thanks again for all the help.

     

    -Oscilated

    Friday, October 10, 2008 4:35 PM