locked
Please Help! Vista has got me totally frustrated- get sensapi.dll bad image errors, among others RRS feed

  • Question

  • I am not sure where to begin! I bought this Dell laptop for my kid, and after a few months, all of a sudden there are these annoying sensapi.dll bad image errors popping up all the time. There is only one user created on the laptop, with administrator privileges. After spending couple of days looking on the web, I got a copy of this file from dll-files.com. However, I am not able to rename/delete the original sensapi.dll, or copy a new one over it. When I try to delete the file, I get a "Destination Folder Access Denied" error.  When I click on Continue in this popup, I get a "User Account Control" popup. When I click on Continue (or cancel) in this popup (since I have administrator privileges I presume I should be able to do so), I get a popup that indicates that the file is being sent to the recycle bin, but actually nbothing happens.

     

    If I try to rename the file, after the above two popups, nothing happens.

     

    I then looked on the web, and thought maybe I should disable user account control. So went to Control Panel->User Accounts. I see myself listed there on the right as having Administrator rights. I see a link for "Turn User Account Control on or off". Clicking, doubleclicking, doing anything on this link pops up the "User Account Control" window again, and clicking onContinue here does nothing!

     

    There is a link in the User Accoutns to Managa anothe account. This also does nothing- again the stupid User Account Control window pops up.

     

    One site said the Windows Defender is the problem. I found that the Windows Defender is Off on my laptop (I dont know how this got turned off..). I tried to turn it on, and get an error saying that this is not a valid Win32 application. Ofcourse, when I downloaded another Windows Defender from Microsoft and tried to install it, it says since my Vista already has this application installed, I cannot reinstall it!! So much for that.

     

    And oh yeah, the performance has come become so slooooow! When I open a folder, it takes several seconds before the files show up (even the control panel takes several seconds, ~30s, to show the images in the right panel).

     

    When I click on the security (Control Panel-System-Security Centr) it says I have complete security, including firewall, malware protection, automatic updates, etc. I did a scan using McAfee (it is installed on the laptop), nothing showed up. Did a scan with some other scanners, but did not find anything (free version of RegCure found some errors, but I am not sure I should buy it and then find it did not fix my problem).

     

     

    So basically, I am completely stuck!  And totally frustrated. I think this whole Vista sucks. My kid uses this laptop for all her school stuff, and now she is completely handicapped! And completely upset and worried.

     

    I hope someone from Microsfot support reads the cycle of problems we are facing and help us out!

     

    Thank you!

     

    -Satya

     

    Thursday, December 20, 2007 5:30 AM

All replies

  • Yeah, just got the same problem. Gee Vista sucks big time..
    Sunday, November 30, 2008 6:36 AM