locked
Help Troubleshooting Outbound Call Routing RRS feed

  • Question

  • I'm trying to setup outbound calling with an OCS Standard install using an AudioCodes MediaPack gateway.  My config is:

     

    Single Std Ed OCS Server

    Single Mediation Server

    Single MediaPack connected to 4 analog lines provisioned off our PBX

     

    When trying to make a call from Communicator I'm getting a 403 error with the following in the event log:

    403  Forbidden
    ms-diagnostics:  12004;reason="No route found";source="clarityocs2.clarityinternal.net";appName="OutboundRouting"

     

    I've configured the following:

    • Single location defined for the forest with the following normalization rule applied to append a '9' to number:
      • Pattern: ^(\d{10})$
      • Translation: +9$1
    • Single Phone Usage record
    • Default Policy (voice) with the one usage configured
    • Single route defined:
      • Target Expression: ^(\d{10})$
      • Gateway address: FQDN of the Mediation server
      • Phone Usages: Defaul Usage
    • On the Std Ed ServerL:
      • Voice is configured to the one location defiled above
    • On the Mediation Server:
      • Default Location Profile is set to the one location defined

    I don't see any errors on either the OCS or Meditaion server - not sure what the problem is here??

     

    Any help appreciated.

     

    Thanks,

    jon

    Thursday, February 7, 2008 4:19 AM

All replies

  • Jon,

     

    We have a similar setup that does work (except PSTN conference call).  What is the setup of your AudioCodes?  Did you set all the routing and number conversions?

     

    Audiocodes provides a sample INI file that you can upload to the gateway.  For me that worked out of the box.

     

     

    Wim

    Thursday, February 7, 2008 1:46 PM
  • I'm using a MediaPack MP-114 FXO.

     

    I did get outbound calling working last night - the Regular Expression I was using for the Route was wrong...when I changed it to this it worked fine:

     

    .*

     

    What kind of voice quality do you get on your calls?  What I'm getting isn't great...it sounds like a decent (but not great...) cell phone connection...much worse than what I get when plugging an analog phone into the same line that the MediaPack is connected to, so I know it's not a problem with the line itself.

     

    jon

    Thursday, February 7, 2008 3:00 PM
  •  

    Jon,

     

    I am glad you solved your routing problem.  There is a nice tool in the OCS Resource Kit called Enterprise Voice Route Helper that is designed to help you troubleshoot these types of problems.

     

    The ms-diagnostics header with the appName="OutboundRouting" indicates the problem occurred within OCS and had never actually reached the gateway.  That is a good indication that there is something wrong with your routing configuration in OCS.

     

    Paul

     

    Wednesday, February 13, 2008 8:45 PM