locked
Manual address book sync not working RRS feed

  • Question

  • Hello, Folks, 

    I'm trying to manually sync my address book from a front end pool server using the abserver -syncnow command but am receiving the following error:

    Triggering Address Book Server synchronization pass - function not available when RTCSRV service is not running.  Start the RTCSRV service.

    I have looked in services to start the RTCSRV service, but did not find it. I manually attempted to start with net start rtcsrv and was notified that the requested service has already been started.

    Any suggestions to get the address book manually sync'd?

    Thank you!
     
    AcroyearUSMC
    Tuesday, December 30, 2008 9:57 PM

Answers

  • It ended up that I needed to open up port 135... all is well now.


    AcroyearUSMC
    • Marked as answer by AcroyearUSMC Wednesday, January 21, 2009 4:53 PM
    Wednesday, January 21, 2009 4:53 PM

All replies

  • RTCSRV is listed in the Services MMC as "Office Communications Server Front-End."  You can find that service in the list or start it with "net start rtcsrv" from a command prompt.


    Mike Stacy | Evangelyze Communications | http://www.evangelyze.net/cs/blogs/mike
    Wednesday, December 31, 2008 3:00 PM
    Moderator
  • Thanks for the reply, Mike... but as you can see in paragraph 3 of my post, I tried exactly that, to no avail.  Thanks for the heads up on the service name, though... it is started in the services list as well.
    AcroyearUSMC
    Friday, January 2, 2009 4:11 PM
  • Sorry, I guess I was reading too fast.  At least you know what it corresponds to now.  :)

    For starters I would look in the OCS event log and search for any general errors as well as anything that comes up when you try to force the sync.  There will probably be some sort of error or warning in there.  You can also try restarting rtcsrv to see if that makes any difference, but that may or may not be an option for you depending on your user community.
    Mike Stacy | Evangelyze Communications | http://www.evangelyze.net/cs/blogs/mike
    Friday, January 2, 2009 9:28 PM
    Moderator
  • I have checked the logs, and only find "information" type entries for the past day.  I have tried the sync again a couple of times today and am still getting Triggering Address Book Server synchronization pass - function not available when RTCSRV service is not running.  Start the RTSRV service.

    I have restarted all the services on that server using the management console, and also using the "net start" command.
    AcroyearUSMC
    Wednesday, January 14, 2009 8:24 PM
  • Just putting this together with your other post on WMI troubles and it seems like you have a few odd issues going on in your environment.  Is there anything unique about your infrastructure in terms of the OS, security, group policy, virtualization, etc.?  It's highly unusual to have these types of problems without any indication of an issue in the event logs.
    Mike Stacy | Evangelyze Communications | http://www.evangelyze.net/cs/blogs/mike
    Wednesday, January 14, 2009 9:30 PM
    Moderator
  • It ended up that I needed to open up port 135... all is well now.


    AcroyearUSMC
    • Marked as answer by AcroyearUSMC Wednesday, January 21, 2009 4:53 PM
    Wednesday, January 21, 2009 4:53 PM
  • Im a domain admin of my OCS servers and had the same problem.
    I add my user in two groups:

    RTCUniversalServerAdmin
    RTCUniversalUserAdmin

    And my problem has solved.
    Friday, July 3, 2009 5:34 PM