locked
Investment details retained after delete, currency wrong RRS feed

  • Question

  • Version 17.0.120.3817 on Windows 7 Home Premium

    I needed to add a new investment to my Brokerage account after a spin-off set of transactions.  From the portfolio view, I selected common tasks>work with investments>set up a new investment; then selected my brokerage account, the >Next and then typed in a name with the 'Add an investment' radio button selected, >Next, selected 'stock' as type, >Next, typed in Symbol and then here's where I went wrong: I selected 'Great Britain' for the region as an experiment since that's where the company is based, I have no need to do transactions in pounds though.  So after this, and entering an initial share buy transaction in the next pane, and selecting Finish, I saw that the price shown in the portfolio view now used the pound as currency.  Now I can't seem to get rid of it.  I've deleted the transaction, then deleted the investment and re-entered as a 'United States' country/region, but the pound symbol stays in the portfolio view.  I have deleted it, repaired the file, deleted it and backuped again, restarted computer, but every time I go through the add new investment routine and enter new transaction in $'s, it still comes back with the pound symbol in the portfolio view!!  It's driving me crazy.  In Tools, Settings, Program Settings, Currency the Base is US Dollar, and in the Account Settings the currency is set as US dollar.  Some remnant seems to remain even after an investment is deleted and I can't figure out how to make it disappear completely.

    Please help.

    Saturday, October 7, 2017 1:58 PM

Answers

  • Hey Cal,

    Just to close this out.  Got back in to it yesterday.  Opened up MM with where I left off, did a restore from one of the early b/u's I did last Sat morning, went through 'Add new investment' routine and this time all was well!  I don't have an explanation other than going through several step changes and b/u's must have eventually overwritten whatever was stuck on 'pounds' for that investment. Updated to latest Pocketsense  version and all seems to be OK now.

    Still have to figure out how to handle spinoffs (what got me in to this in the first place), so will look for or start another thread for that.

    Thanks so much for your help.

    Jon

    • Marked as answer by Joryde Sunday, October 15, 2017 6:39 PM
    Sunday, October 15, 2017 12:42 PM

All replies

  • You seem to have found the file and account currency settings already.

    I think you are saying that this problem only occurs for only the one security. Go to the InvestmentDetails for that security, and make sure Country/Region is set to United States.

    If that does not do it, there are alternative things to try. Do you use Pocketsense?

    Saturday, October 7, 2017 2:54 PM
    Moderator
  • Yes, only the one security.

    Investment Details shows United States (also shows $10.00 as most recent price).  I had to go through the 'Set up new investment', as my present state was deleted.  Still shows the 'pound' symbol in portfolio view with a converted amount ( I entered initial transaction as 38 shares @ $10, it's showing 13 pounds due to currency conversion setting of 1.3).

    I do use Pocketsense, but I on a limited set of Accounts, and mostly just for prices.T

    Thanks very much,

    Jon

    Saturday, October 7, 2017 3:42 PM
  • Some update:

    The question about Pocketsense gave me an idea.  I added the new investment to my sites.dat file and then ran it.  Imported the latest price just fine, but it still showed a converted to pounds amount in portfolio view after the import!

    Saturday, October 7, 2017 4:00 PM
  • The problem only occurs for that one investment?

    I would be inclined to create a new Money file, as a test, and see if the problem is associated with some global setting or specific to that investment or account.

    If it is only the investment, you could remove the symbol from that investment, and rename the investment to something you will not want to use. Then create a new investment, with the symbol.

    If that works, and receives quotes properly, you can delete the problem investment by deleting all of its transactions and then deleting the investment. You might decide to export the account to QIF first. I don't know how much is in that same account. If you decide to go that way, check back for some ideas on that.

    Saturday, October 7, 2017 4:45 PM
    Moderator
  • I made a test file, new account, and added the same investment.  No issue in portfolio view for that one. 

    Somehow, it seems that first time I chose 'Great Britain' as the country/region is stuck in some file and does not get changed or deleted when I delete the investment, or edit it's details, or any other change that should effect it.  Unless you have an idea where, it looks like I'm going to have to try to use a backup, and re-enter transactions since then (2nd qtr end).  Not terrible, but  was hoping it was a known issue.  Guess not.  I could try renaming as you mention.  I noticed that Great Britain comes after Brazil in the currency setting box, but in the 'Set up new investment' dropdown it comes after Ghana.  Strange.

    Thanks very much for your time.

    Saturday, October 7, 2017 5:12 PM
  • How many transactions are you talking about? Or is losing the price history that concerns you?

    Another option could be to set that currency to 1:1 exchange rate. Let TheCo (symbol XYZ) be the stock in question. Rename that to TheCo_old and blank the symbol. Set the quantity of TheCo_old  to zero, perhaps by entering a remove shares.  Then still create the new investment named TheCo (symbol XYZ). Do an AddShares of TheCo.

    If there are not all that many transactions, make a large dummy AddShares of the TheCo, dated before all
    other transactions, into the account register.

    Then go to investment TheCo_old and choose InvestmentActivities.
    Change each transaction to TheCo using the drop-down list.  Start with the newest transaction. I would double-click the transaction to open it for edit.

    In any case, keep going until there are no more TheCo_old transactions remaining.  At that point you can "delete" TheCo_old. You can do that, because there are no longer any TheCo_old tranactions.

    Finally, delete the dummy AddShares that you put into your
    register; accept the warning.

    go to investment TheCo_old  and choose InvestmentActivities.

    Saturday, October 7, 2017 5:37 PM
    Moderator
  • Hey Cal,

    Just to close this out.  Got back in to it yesterday.  Opened up MM with where I left off, did a restore from one of the early b/u's I did last Sat morning, went through 'Add new investment' routine and this time all was well!  I don't have an explanation other than going through several step changes and b/u's must have eventually overwritten whatever was stuck on 'pounds' for that investment. Updated to latest Pocketsense  version and all seems to be OK now.

    Still have to figure out how to handle spinoffs (what got me in to this in the first place), so will look for or start another thread for that.

    Thanks so much for your help.

    Jon

    • Marked as answer by Joryde Sunday, October 15, 2017 6:39 PM
    Sunday, October 15, 2017 12:42 PM