locked
The Customer Portal Client-side editing tolls still enabled RRS feed

  • Question

  • I’m working with Customer Portal Solution (1.0.0012). I have linked the “Customer Portal Administrators” Web Role to a test contact record to allow edit portal capabilities. In this manner I can show client side editing tools. The problem is that if I remove the "Customer Portal Administrators" Web role link to previous contact record, the permissions to use client-side tools still show. Next, if I add a new contact record it will have client-side edit tools capabilities enabled (no Web role link ). So, I cannot reset default status which no one has the permission to edit portal using client-side tools. I have tried from others PC and liveid.
    Thursday, January 12, 2012 9:55 AM

All replies

  • It sounds like caching is the culprit.  Have you set up your cache invalidation urls in CRM? And are your cache invalidation plugin steps enabled?  Keep in mind you cannot use an IP address or localhost - you have to use a domain name.  I also recommend you set up a cache invalidation link on your browser toolbar - you can click the button and immediately invalidate your site's cache.  This is very effective at making changes and configuring your demo environments.  Here is an article on how to set up that link: http://community.adxstudio.com/Default.aspx?DN=ff663ebf-1a78-4afc-a8d1-19c3e171dddf

    To validate that caching is causing the problems, simply recyle IIS or the app pool for your website and then refresh your browser page.  If the problem goes away, it was caching.


    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com
    Tuesday, January 17, 2012 11:35 PM
    Moderator
  • Thanks for reply, but I had already tried all the methods to invalidate the cache with no results.
    Tuesday, January 24, 2012 8:34 AM
  • If you have recycled your app pool of your IIS server, then there is no chance of the problem being server-side cache related.  It either is that you don't have the data configured correctly, you changed the code of the website or the web.config, or your browser is caching when it should not.  Please check your browser settings.  The check for new pages setting should be set to automatic.  The portal is known to work well in this area so there is something in your environment.  One thing we could do is to arrange for a web meeting where I can help you troubleshoot.  I am available on Friday.  Send an email to me at firstname.lastname@adxstudio.com.
    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com
    Tuesday, January 24, 2012 2:17 PM
    Moderator