locked
PluginType entity doesn't contain attribute with Name customworkflowactivityinfo RRS feed

  • Question

  • Hi ,

    Recently we migrated the CRM 2011 database from sql 2008 to SQL 2012  and upgrade the Rollup from 6 to 13. After the migration i have requested to change the existing workflow and redeployed in development server by using plugin registration tool. Now i tried to move the workflow from Development to UAT server. When i import the workflow, i am getting the below error.

    'PluginType' entity doesn't contain attribute with Name = 'customworkflowactivityinfo'

    I checked in the both environment. customworkflowactivityinfo is missing in UAT DB.
    I have checked in the production server and found that customworkflowactivityinfo is missing there also.

    Please help me to deploy the workflow in UAT and Production. 

    Wednesday, October 21, 2015 10:38 AM

All replies

  • Hi Albert,

    This blog suggests that UR 15 resolves the issue, is there any reason why you chose UR 13 as a stop? I think that UR 18 is out so I'd use that one.

    Regards


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Wednesday, October 21, 2015 10:48 AM
  • Thanks for your reply. 
    Wednesday, October 21, 2015 11:20 AM
  • Hi Rickard,

    In both environment we upgraded Rollup 13. is there any other way to sort out this issue?

    Wednesday, October 21, 2015 11:43 AM
  • Hi Albert,

    Not if it's a bug that is fixed in UR 15. What are your reasons to stop at UR 13, is there something in your solution that will break in higher rollups?

    Regards


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Wednesday, October 21, 2015 11:46 AM
  • Hi Rick,

    I have upgraded rollup 15 in UAT server ( APP server & DB server). But column is still missing. And after further investigation, i verify version thru browser and login into organsiation url and its show as i mentioned below. APP version and DB versions are not matching.

     So i try to update from Deployment manager. I am getting an error.

    Error| Installer Complete: OrganizationDatabaseHotFixer - Error encountered
    07:53:27|  Error| Exception occured during Microsoft.Crm.Tools.Admin.OrganizationDatabaseHotFixer: Action Microsoft.Crm.Tools.Admin.InstallDatabaseUpdatesAction failed.
    InnerException:
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: x An item with the same key has already been added.
       at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
       at Microsoft.Crm.Metadata.PreloadedOptionSetMetadataDataProvider.LoadNormalOptions(IPreloadedMetadataInitializationContext context, Boolean initializeEnumOptionProvider)

    Please advise.

    Thursday, October 29, 2015 5:46 AM
  • Hi,

    Something seems to have gone wrong somewhere. You may have some luck in applying later UR, but there's no guarantee, however if you want to open an issue with MS they will tell you to apply the latest rollup first.

    Regards


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Thursday, October 29, 2015 12:29 PM