locked
Project Server 2010 - Unable to upload documents in the Project Documents Library RRS feed

  • Question

  • Hi,

    For 1 of the projects, in the Project Tab, click on "Documents" -> Project Documents.  Click on "Add document".   When I click "submit", I get an "Error: Access Denied".   If I click "Go back to site", the document is shown in the list but other project team members are unable to see the document. However, I can create another folder, upload documents to the folder I created without error.   The documents I uploaded in the folder I created can be viewed by other project team members.

    Thanks,

    G Despojo

    Thursday, May 19, 2011 6:15 AM

Answers

  • Hello GatD,

    Read Paul's blog to see if should help to fix your issue.

    http://ghamson.wordpress.com/2011/07/11/manually-adding-users-to-project-workspace-project-site-in-projectserver-ps2010-ps2007-epm/

    Thanks,


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    • Marked as answer by epmXperts Wednesday, November 7, 2012 8:21 PM
    Thursday, July 14, 2011 11:29 AM
  • Hi GatD

    It has been long since this thread has been posted or updated, closing this thread assuming this has been already resolved, closing is necessary in order to keep the forum moderated

    please feel free to either reopen this thread or create a new one if you feel it has not been resolved & warrants further discussion

    Also would suggest if you find an answer or a workaround to this question / issue, please share in order for other forum members to get benefit of your experience


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com

    • Marked as answer by epmXperts Wednesday, November 7, 2012 8:21 PM
    Wednesday, November 7, 2012 8:20 PM

All replies

  • As a quick suggestion just try to re-synch the project site and soon after that have a look on the queue to find is there any WssReportingSynch job failed or not.

    You can re-synch your project site from Server settings -> Project Workspace options


    Sachin Vashishth MCTS
    Thursday, May 19, 2011 6:29 AM
  • Hi,

    Can't fine the Project Workspace options in Server Settings.

    Went to Project Site, chose the project I wish to synchronize & clicked on "Synchronize".  

    Checked queue jobs & noted the following jobs ran successfully.   Reporting (Project Synch) & Project Site Membership Synchronization.   However, I still encounter the same error.

    Thanks,

    G Despojo  

     

    Thursday, May 19, 2011 6:40 AM
  • Are you automatically synchronizing the project web access users with project workspace or you are manually giving rights to users on project workspace.

     

    If you giving permission manually then those set of users might not have permission on that doc library.

     

    Form first view it seems to be permission issue with that particular doc library. can you check the permission of project documents library means which user have which permissions.


    Sachin Vashishth MCTS
    Thursday, May 19, 2011 7:03 AM
  • Hi,

    The user was given "Project Manager" permissions to the project.  Global permissions were set to "Project Manager" as well.   I've also added a "Contributor" permission for the account.

    My own account with Administrator privelege also gets the same error.

    Thanks,

    G Despojo

     

    Thursday, May 19, 2011 11:43 PM
  • By the way, how do we check for permissions to the project library?
    Thursday, May 19, 2011 11:43 PM
  • By the Way have u checked the ULS logs, this will give you correct pointer to move further on issue. There must be some error description while creating or uploading doc in ULS logs

    By default ULS logs are located at \Program Files\Common Files\Microsoft Shared\Web server extensions\14\LOGS.

    As even a administrator also getting the same error there is something wrong with that doc library or workspace.

    Just to give it a try why dont you delete the doc library and create a new project document library.

    But before that have a backup of the data in your document library.


    Sachin Vashishth MCTS
    Friday, May 20, 2011 6:32 AM
  • Hello GatD,

    Read Paul's blog to see if should help to fix your issue.

    http://ghamson.wordpress.com/2011/07/11/manually-adding-users-to-project-workspace-project-site-in-projectserver-ps2010-ps2007-epm/

    Thanks,


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    • Marked as answer by epmXperts Wednesday, November 7, 2012 8:21 PM
    Thursday, July 14, 2011 11:29 AM
  • Hi GatD,

    To check the Doc library permissions, open the doc library and click the Library tab above the Ribbon, then click the Library settings on the ribbon. On this page you will see a link "Permissions for this document library", does this doc library inherit its permissions? Also do you get the same issue if you navigate directly to the Project Site then click the Project Documents link rather than going via the Project Details page in PWA? 

    If you have manually added permissions it might be worth looking at my blog article  (https://pwmather.wordpress.com/2011/07/11/manually-adding-users-to-project-workspace-project-site-in-projectserver-ps2010-ps2007-epm/ ) as Amit suggested - thanks Amit! By the way I also post the ghamson blog, that is one of my colleague's blogs!

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Thursday, July 14, 2011 12:25 PM
  • Hi GatD

    It has been long since this thread has been posted or updated, closing this thread assuming this has been already resolved, closing is necessary in order to keep the forum moderated

    please feel free to either reopen this thread or create a new one if you feel it has not been resolved & warrants further discussion

    Also would suggest if you find an answer or a workaround to this question / issue, please share in order for other forum members to get benefit of your experience


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com

    • Marked as answer by epmXperts Wednesday, November 7, 2012 8:21 PM
    Wednesday, November 7, 2012 8:20 PM