locked
CRM Email Router Configuration RRS feed

  • Question

  • I am trying to configure my CRM 2011 email router to use Local System Account.

    1) I have IFD enabled- The URL is the Email Router Configuration Manager --> Deployments is currently pointing to the INTERNAL URL. Is this correct?

    2) I addeed the computer account to the PrivUserGroup in AD. Since we have multiple CRM's in our AD, how can I verify which CRM group my CRM is using?

    3) When I try to load data, it fails with unable to retrieve user... See attachement

    Wednesday, October 10, 2012 5:55 PM

All replies

  • Is the e-mail router installed on the CRM server? If not, then I don't think Local System account will work, you will need to use the username and password of a CRM user.

    Wednesday, October 10, 2012 9:39 PM
    Moderator
  • Email router is installed on the CRM server and it is in the samedomain. I want to use the LOCAL SYSTEM account, not a username and password.

    Thursday, October 11, 2012 2:02 PM
  • If the e-mail router is installed on the same computer as the CRM server then you can use the local system account. In this case, I don't think you need to add the computer account to the PrivUserGroup. This is only needed if the e-mail router is installed on a different server.

    I now think that LocalSystem does not work when claim-based authentication and IFD are enabled. I cannot make Local System work on my deployment and I am using IFD.

    Thursday, October 11, 2012 2:22 PM
    Moderator
  • So I need to create a new user ID and password for Email Router? What permissions will this account need?
    Thursday, October 11, 2012 2:26 PM
  • Hi,

    In my case worked with Local System account for running E-mail Router service and deployment administrator credentials for the access credentials in Deployments tab.

    Monday, October 15, 2012 9:14 PM
  • How did you configure it?
    Tuesday, October 16, 2012 1:28 AM
  • I set up next parameters in section E-mail Router Configuration Manager -> Deployments

    Deployment: My Company

    Microsoft Dynamics CRM Server: https://{FQDN}/Orgname (FQDN same as in Deployment Manager)

    Access Credentials: Other Specified

    Username: domain\DeplAdmUser

    May be I also added Deployment Administrator user to PrivUserGroup of current CRM deployment.

    Tuesday, October 16, 2012 12:31 PM
  • That's right; deployment admin must be added to PrivUserGroup. Here are the details of permissions for Granting CRM Deployment Administrator Permissions to the CRM Active Directory Groups and How to assign the minimum permissions to a deployment administrator in Microsoft Dynamics CRM 4.0

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful" Thanks, Imran Abbasi


    Wednesday, October 17, 2012 3:27 AM
  • I added my User in the Deployments tab as a System Administrator in CRM.

    I also added the user to the PrivUserGroup.

    Still does not work.

    Does this user also needs to be a CRM Deployment Administrator in Deployment manager?

    Wednesday, October 17, 2012 3:51 AM
  • I am having the same issue.

    Any updates?

    Thursday, October 18, 2012 4:23 PM
  • This configuration requires a machine trust between the computer where the E-mail Router is running and the computer where Microsoft Exchange Server is running, as well as membership in the privUserGroup. See the implementation guid for more details.

    I hope this helps. If my response answered your question, please mark the response as an answer and also vote as helpful. Michael Mayo

    Thursday, October 25, 2012 11:32 AM
  • Michael:

    Probably a silly question, but how do I go about setting up the machine trust?  I looked in all the documentation, and while it tells you to do this, it does not state how?

    Thanks in Advance

    Ken


    Kenneth Clebak

    Monday, September 23, 2013 3:09 PM
  • As stated here: http://social.microsoft.com/Forums/en-US/6ae70ca3-49a1-4f6d-a962-9fb8aa10120a/crm-2011-email-router-fails-to-load-data?forum=crmdeployment

    1. Follow KB926642 and set DisableLoopbackCheck on the machine where CRM resides: http://support.microsoft.com/kb/926642.
    2. You can't use Local System as Access Credentials in Email Router with IFD. The account you need to use, must be an account that has CRM permissions to read queues and user settings. You must add this account to PrivUserGrup in AD if it isn't Deployment Administrator.

    Cheers!
    Tom
    • Edited by Tomasz Oledzki Thursday, October 10, 2013 8:34 AM Edited links
    Thursday, October 10, 2013 8:33 AM