locked
BitLocker startup key on USB does not work if readyboost is enabled in Win 8 Pro RRS feed

  • Question

  • Hi all, this is my first post to Technet forums and I'm not sure where I should drop it.

    I have upgraded to Win 8 Pro and found that BitLocker startup keys copied to USB thumbdrives do not allow to start the computer. The .BEK file is created on the thumbdrive but the system won't start on it. After I turned off ReadyBoost I was able to start the computer with newly created keys.

    So I was wondering if there is any known compatibility problem between BitLocker and ReadyBoost in Win 8 Pro.

    I found a few threads related to BitLocker but they are all on Win 7 forums so I'm not sure if I should post my question there.

    Many thanks for any help!

    Wednesday, February 13, 2013 6:06 PM

Answers

All replies

  • Ok, did some more tests. It seems that it is actually not related to ReadyBoost but to another thumbdrive being present on another USB port. Tried with several different USB sticks and had trouble with BitLocker not recognizing the startup key when the machine boots. I have one Sony (2GB) and several SuperTalent thumbdrives (1x4GB and 4x 8GB). The Sony thumbdrive can be left plugged in and doesn't cause trouble, but SuperTalent thumbdrives cause trouble. I use 2 of the 8GB sticks for the startup keys. Maybe BitLocker checks for some hardware ID and these SuperTalents all have identical IDs that confuse BitLocker? The funny thing is that I have labeled the stick used for startup keys "1" and "2" with a marker pen, and startup issues only occur with key "1" and never with key "2".

    So the title should rather be "BitLocker startup key on USB does not work in Win 8 Pro if some other thumbdrive is attached to the computer"

    Wednesday, February 13, 2013 8:19 PM
  • You might ask in the Windows 8 Installation, Setup, and Deployment foru.

    Otherwise, see the list of Windows 8 forums:

    Windows 8 IT Pro

    Karl


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer



    My Blog: http://unlockpowershell.wordpress.com
    My Book: Windows PowerShell 2.0 Bible
    My E-mail: -join ("6B61726C6D69747363686B65406D742E6E6574"-split"(?<=\G.{2})",19|%{[char][int]"0x$_"})

    Friday, February 15, 2013 10:59 PM
  • Thank you very much Karl, and sorry for coming back only now. I was expecting to receive emails when this thread had new posts but I didn't see anything coming to my inbox. Still new here and Learning I guess :-)

    In the meantime I found out that the problem only appears when the other thumbdrive is plugged in one of the rear USB ports of my computer (attached directly to the motherboard). If the other thumbdrive is instead plugged in one of the front USB ports the computer starts up nicely.

    The Windows 8 IT Pro link is now in my favorites. There is a section on security that already has a few posts about BitLocker and seems the right place to post my question. Not sure why I didn't find it earlier on... I'll have a look through it and see if someone else already had the same issue.

    Cheers,

    saw006

    Thursday, February 21, 2013 9:02 AM