locked
Urgent, Please help : Displaying website in IFrame in web Microsoft Dynamics CRM 2011 RRS feed

  • Question

  • Hello All,

    I am new to web Microsoft Dynamics CRM 2011. I want to display our client website in IFrame, but I am unable to see because getting an error in firebug console : "Blocked loading mixed active content". Steps I followed are:

    1. Login to web Microsoft dynamics CRM.

    2. On the left side at bottom corner, click on 'Settings' -> 'Customizations' -> 'Customize the System'

    3. A window pops up, now in this popped up window on the left side expand 'entities' then under 'entities' expand 'opportunity' then under 'opportunity' select 'Forms'.

    4. A grid is shown, now select 'opportunity' from grid. So the 'opportunity' form will get opened, in that form on the top select 'Insert' tab, under this 'Insert' tab, there is an option to select 'IFrame' in the top menu. Fill the fields in 'Add an IFrame'.

    5. Then select Home tab and then click on Save and then Publish. Now again go to the main Home page of MS CRM on the left side click on 'Sales' -> 'Opportunity', now a grid open in that select any opportunity.

    6. A popup window opens, but in the section where I added IFrame there is no content in that IFrame, however the url I provided that points to (assume) a website, even then getting no data of website in the IFrame.

    7. On checking in console of Firebug in Firefox there is error : "Blocked loading mixed active content for  http://localhost/SomeTest/IFrame".

    Problem:

    So the IFrame is loading, but the website which in that IFrame is not loading (like empty IFrame), but a 'localhost website url' is assigned to that IFrame. e.g. I want check it for 'http://localhost/SomeTest/IFrame', and this website does not load in that IFrame and on checking in console of Firebug in Firefox there is an error : "Blocked loading mixed active content for http://localhost/SomeTest/IFrame" website .

    Please help.







    • Edited by JaiHariHar Thursday, August 22, 2013 10:42 AM
    Wednesday, August 21, 2013 10:26 AM

Answers

All replies

  • Is your crm 2011 configured for HTTPS?

    Calling HTTP page from HTTPS is not secured. 

    In such cases HTTP content within HTTPS page is considered as threat, because HTTP content can be modified by attackers.

    Mixed content error refers to the mixing of HTTPS and HTTP content.

    • Proposed as answer by Yatin Babaria Wednesday, August 21, 2013 10:58 AM
    • Unproposed as answer by JaiHariHar Wednesday, August 21, 2013 11:24 AM
    Wednesday, August 21, 2013 10:56 AM
  • Thanks for the reply, but how can I configure the CRM 2011 to accept 'HTTP' instead of 'HTTPS' ? On the day before yesterday I was able to see our website in that IFrame which was pointing to http://localhost/.. , but from yesterday I am unable to see our website in that IFrame.
    • Edited by JaiHariHar Wednesday, August 21, 2013 11:23 AM
    Wednesday, August 21, 2013 11:05 AM
  • You can also set the iframe url in the onload event of form like:-

    function setUrl() {
      Xrm.Page.getControl("IFRAME_NAME").setSrc("http://www.msn.com");
    }

    Please change IFRAME_NAME and website URL according to your requirements.


    Regards Faisal




    • Edited by Faisal Fiaz Wednesday, August 21, 2013 12:11 PM
    Wednesday, August 21, 2013 12:10 PM
  • You can also set the iframe url in the onload event of form like:-

    function setUrl() {
      Xrm.Page.getControl("IFRAME_NAME").setSrc("http://www.msn.com");
    }

    Please change IFRAME_NAME and website URL according to your requirements.


    Regards Faisal





    Thanks for the reply, where is 'onload' event of form to write the above code? for onload , do I need to add a javascript page as a web resource for that IFrame OR is there any other way by which I can directly write the javascript code in the CRM 2011 ?
    Wednesday, August 21, 2013 2:52 PM
  • Hi

    You need to restrict cross-site scripting on your iframe. To do this, double-click on the iframe on the customize opportunity form and you will see a checkbox to restrict cross-site scripting.

    I hope this answers your question.

    • Proposed as answer by Roshan Mehta Thursday, August 22, 2013 6:08 AM
    • Unproposed as answer by JaiHariHar Thursday, August 22, 2013 7:42 AM
    Thursday, August 22, 2013 6:08 AM
  • Hi

    You need to restrict cross-site scripting on your iframe. To do this, double-click on the iframe on the customize opportunity form and you will see a checkbox to restrict cross-site scripting.

    I hope this answers your question.


    Thanks for the reply, but I have already checked by unchecking the restrict cross-site scripting checkbox and it's doesn't work still.
    Thursday, August 22, 2013 7:42 AM
  • Have you tried loading the iFrame within CRM from a different browser? e.g. Internet Explorer or Chrome?
    Thursday, August 22, 2013 7:55 AM
  • Have you tried loading the iFrame within CRM from a different browser? e.g. Internet Explorer or Chrome?

    It's working for IE and Chrome, but not for Firefox !
    Thursday, August 22, 2013 9:34 AM
  • Thankyou all for your comments. I found solution in my other thread, by disabling the protection for firefox, for more information refer : 

    http://stackoverflow.com/questions/18251128/why-am-i-suddenly-getting-a-blocked-loading-mixed-active-content-issue-in-fire


    • Marked as answer by JaiHariHar Thursday, August 22, 2013 11:31 AM
    • Edited by JaiHariHar Thursday, August 22, 2013 11:36 AM
    Thursday, August 22, 2013 11:30 AM