locked
How to set the Task Start Date and Due Date RRS feed

  • Question

  • We create a Task in Cases under Service.
    We found that under Case in Activities cannot be set the Start Date,
    but we found that in the Workplace the Start Date and Due Date are same.
    Can we set the Start Date and Due Date as different?
    Monday, February 9, 2009 7:00 AM

Answers

  • hi KL,

    By default Start date is not shown on the form. To achieve your requirements, you need to add this field to form.

    1. Simply go to customizate entity in settings area,
    2. open task for customization,
    3. click Forms and Views tab and
    4. double click "form -- the main application form" for customization.
    5. Click Add Field and add Start date on the form.
    6. Click Save and then don't forget to publish the task entity.
    once done, you will be able to see start date in task form. Now you can separately set both of these dates alongwith respective time.


    Sohaib Ahmad [Business Management Solution Specialist] http://www.solutiontalk.blogspot.com
    • Marked as answer by KL_Poon Tuesday, February 10, 2009 7:51 AM
    • Unmarked as answer by KL_Poon Tuesday, February 10, 2009 8:13 AM
    • Marked as answer by KL_Poon Wednesday, February 11, 2009 5:35 AM
    Monday, February 9, 2009 10:04 AM
  • Dear KL_Poon,

    Publishing any customization is very simple task.

    1. In Settings area go to customization -->  Customization Entity
    2. Open the entity you want to customize [or you have already customized]
    3. Click More Actions --> Publish on that entity's customization area.

    Hope this resolves your issue :)


    Sohaib Ahmad [Business Management Solution Professional] http://www.solutiontalk.blogspot.com
    • Marked as answer by KL_Poon Wednesday, February 11, 2009 5:35 AM
    Wednesday, February 11, 2009 5:32 AM

All replies

  • Is the start date a custom field that you created on the task form? 
    You should be able to set both the fields both under cases and the activities tab. 
    You might have custom JavaScript code on the form that disables fields if the behavior you describe is true.

    Hassan.
    • Proposed as answer by Hassan Hussain Monday, February 9, 2009 10:00 AM
    Monday, February 9, 2009 10:00 AM
  • hi KL,

    By default Start date is not shown on the form. To achieve your requirements, you need to add this field to form.

    1. Simply go to customizate entity in settings area,
    2. open task for customization,
    3. click Forms and Views tab and
    4. double click "form -- the main application form" for customization.
    5. Click Add Field and add Start date on the form.
    6. Click Save and then don't forget to publish the task entity.
    once done, you will be able to see start date in task form. Now you can separately set both of these dates alongwith respective time.


    Sohaib Ahmad [Business Management Solution Specialist] http://www.solutiontalk.blogspot.com
    • Marked as answer by KL_Poon Tuesday, February 10, 2009 7:51 AM
    • Unmarked as answer by KL_Poon Tuesday, February 10, 2009 8:13 AM
    • Marked as answer by KL_Poon Wednesday, February 11, 2009 5:35 AM
    Monday, February 9, 2009 10:04 AM
  • I follow your step is success to configure and saved, under Case in Activities still cannot be set the Start Date.
    Tuesday, February 10, 2009 8:28 AM
  • Hi KL_Poon,

    I've tested my suggested solution and it worked in my case. Have you shown the start date field on the form? Is it visible now? Have you published it after customizing the task entity?

    Keep in mind that you will have to customize every activity type {task, phone call, email, service activity, ....} individually and then will have to publish each.


    Sohaib Ahmad [Business Management Solution Professional] http://www.solutiontalk.blogspot.com
    Tuesday, February 10, 2009 9:41 AM
  • In customization, I can see the Start Date field.
    I may be not understand how to publish it after customizing the task entity.
    Wednesday, February 11, 2009 4:11 AM
  • Dear KL_Poon,

    Publishing any customization is very simple task.

    1. In Settings area go to customization -->  Customization Entity
    2. Open the entity you want to customize [or you have already customized]
    3. Click More Actions --> Publish on that entity's customization area.

    Hope this resolves your issue :)


    Sohaib Ahmad [Business Management Solution Professional] http://www.solutiontalk.blogspot.com
    • Marked as answer by KL_Poon Wednesday, February 11, 2009 5:35 AM
    Wednesday, February 11, 2009 5:32 AM
  • OIC. Thanks for your help!
    Wednesday, February 11, 2009 5:36 AM