locked
Upgrading CRM 4.0 32 bit to 64 bit - Installation is hanging RRS feed

  • Question

  • Hi CRM Professional,

    I'm trying to upgrade crm 4.0 32 bit to 64 bit.

    CRM 4.0 Installation hangs here -

    Microsoft.CRM.Setup.Server.AssignNtfsPermissionOnWebServiceDirectoriesAction - does anyone know how I can fix this?  Where can I start troubleshooting?  Where is the installation log files?

    I only have 1 server - SERVER 2008 R2 (DNS, AD, SQL SERVER 2008 R2, CRM).  - (Currently CRM 4.0 32 bit is on another server 2003). 

    Here is my log....it stops here...

    04:22:45|   Info| Executing Install action: Microsoft.Crm.Setup.Server.ConfigureMimeMap
    04:22:45|   Info| MetabasePath: /LM/W3SVC/1
    04:22:45|   Info| Executing Install action: Microsoft.Crm.Setup.Server.ConfigureHelpVirtualDirAction
    04:22:45|   Info| WebAppRoot: /LM/W3SVC/1/ROOT
    04:22:46|   Info| Executing Install action: Microsoft.Crm.Setup.Server.CreateHelpApplicationAction
    04:22:46|   Info| HelpAppRoot: /LM/W3SVC/1/ROOT/Help
    04:22:46|   Info| Executing Install action: Microsoft.Crm.Setup.Server.UseCustomErrorPagesAction
    04:22:46|   Info| Executing Install action: Microsoft.Crm.Setup.Server.UseCustomErrorPagesAction
    04:22:47|   Info| Executing Install action: Microsoft.Crm.Setup.Server.CreateWPGAction
    04:22:47|   Info| Executing Install action: Microsoft.Crm.Setup.Server.AssignLsaPrivilegesAction
    04:22:48|   Info| Executing Install action: Microsoft.Crm.Setup.Server.AssignNtfsPermissionsOnWebServiceDirectoriesAction
    • Edited by TOURISTSIS Monday, August 10, 2015 9:30 AM
    Monday, August 10, 2015 7:17 AM

All replies

  • did you walk through this page: https://support.microsoft.com/en-us/kb/950100

    CRM 4.0 and Server 2008 R2 require some extra steps, since R2 is so different form Server 2003, CRM 4.0's original install target. 

    Also, make sure you do a fresh install on CRM, THEN migrate your old database over.


    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    • Proposed as answer by Wayne Walton Monday, August 10, 2015 12:43 PM
    Monday, August 10, 2015 12:42 PM
  • I did went through that step prior. Funnie enough that application hangs for about 50 minute then continue, I guess it was still installing or working on something. Thanks much though!
    Tuesday, August 11, 2015 12:22 AM