locked
Filtered Syncronization with different values. RRS feed

  • Question


  • Hi,

    I create a Scope named 42609_scope_service_request_tab1.0.0 which has only one table CR_SERVICE_REQUEST.
    The Primary key is Composite(SERVICE_REQUEST_ID_N varchar(30) , TOWN_CD_C  varchar(20)) with filter keyl  as BILLING_UNIT_C(varchar(30)).Filter value is (Billing_Unit_C in ('4652').
    I get all the necessary values into my local database in my laptop.

    I delete my old database.
    I recreate a new Database on my machine.
     
    Later I create new Scope named 54568_scope_service_request_tab1.0.0 on same table on server.
    I give a filter value of '2411','2429','2488','4445','4724' to my same filter Column BILLING_UNIT_C.
    After Syncronization, values with Older values(Billing_unit_C ='4652') are in my local database.
    I check in Server Database table sync.scope_Config  and in config.xml you can see respective(correct) BILLING_UNIT_C values in table.

    I am still not able to configure why I am getting old values to syncronize.

     Regards,

    Sachin K

    Monday, April 22, 2013 10:44 AM

Answers

All replies

  • how many selectchanges SPs do you have on the table?
    Tuesday, April 23, 2013 10:55 AM
  • Hi June,

    I tried with below activity and got the below result.

    I took two desktops  A and B.

    Desktop A :

    On Desktop A I created a filtered scope for a Table CR_SERVICE_REQUEST with Filter Value as 4142.

    I got the values in my Client Desktop with Values for '4142'.

    On Desktop B I again  created a filtered scope for a Table CR_SERVICE_REQUEST with Filter Value as 5886.

    I got the values in my Client Desktop with Values again  for '4142'.

    I have only one Stored Procedure for the table named dbo.CR_SERVICE_REQUEST_selectchanges.

    To my surprise , when I check in Sync.Scope_cofig table, as usual I have two Scopes respectively.

    In Config.Xml for the respective Scope I do have value as 4142 and 5886,but still I get the value as 4142.

    Am I missing a step?

    Regards,

    Sachin K

    Friday, April 26, 2013 6:26 AM
  • Hi,

    I am using Below Environment.

    Microsoft Visual Studio 2008.

    Sync Framework 2.1 .

    OS : Windows 7.0 .

    Regards,

    Sachin K

    Sunday, April 28, 2013 9:43 AM
  • your scopes are using the same selectchanges sp.

    you should be using a filtered scope template if you want multiple scopes against the same table but using different values.

    or if you dont want to use templates, you should specify SetCreateProceduresDefault

    see: http://jtabadero.wordpress.com/2010/02/28/provisioning-additional-scope-using-sync-framework%E2%80%99s-sync-scope-provisioning/

    • Marked as answer by sakulkarni83 Monday, April 29, 2013 9:15 AM
    Monday, April 29, 2013 1:18 AM