none
Nodes are stuck in provisioning mode RRS feed

  • Question

  • I was doing a maintenance task as I do every month for windows updates.  However this month, 6 of my nodes remain in provisioning mode and I cannot get them out.  Is there a table in the database that sets this value?  I have searched every table I can think of and nothing seems to correlate with the provisioning state.  I have tried rebooting everything multiple times.  I have ran tons of powershell things....the two most specific to the operation below.  I have tried hitting the cancel provisioning link in the gui.  Nothing seems to want to get them out of this state.  Can anyone help?

    set-hpcnodestate -force  -state offline -name <nodename>

    Get-HpcOperation -NodeName hpc2008node | Stop-HpcOperation

    Thanks!

    Wednesday, May 1, 2013 2:23 PM

All replies

  • This is for Windows HPC 2008 R2 SP3

    Wednesday, May 1, 2013 2:53 PM
  • Hi rmagnello,

    It's possible that an untested update has caused your problem.

    Things to try:

    • install updates and reboot head node
    • delete compute nodes from cluster and allow them to 'call back' into the head node then re-apply their deployment template.  (note:  applying a bare-metal deployment template to a node which 'calls in' will only run the template's maintenance tasks.

    If these attempts to resolve you problem do not succeed, please provide instructions to reproduce the problem.

    Thanks,
    --Brian

    Friday, May 17, 2013 11:30 AM
  • Yes, this is what I eventually had to do and it did work.  Thanks for the info.

    Friday, May 17, 2013 1:33 PM