locked
Problem with full (bare metal) restore RRS feed

  • Question

  • Tried to do a full restore and encountered the following error "Error:  Could not load VDS"

    This occured as the restore was attempting to compute the the remaining time.  In other words the last step.

    My system consists of the following:

    Windows 7 Pro

    64GB SSD boot drive with the normal 2 partitions (system and OS)

    Other info:  Nightly backups are always successful, and I can restore individual files/folders normally.  The failure occurs regardless of whether or not I use a USB thumbdrive or the WHS 2011 client restore CD.  It also doesn't matter if I try to restore both partitions, or just the C (OS) partition.  Additionally, this is a recent problem, the process has been successful in the past (several months ago).

    I'd appreciate any help that can be offered.  Logs are also available if needed, but everything looked fine until the aforementioned error.

    UPDATE:  I tried to do a full restore to a new bare drive on a different client computer and am getting the same error.  I tried to restore the OS drive from 4 different client computers (to this new drive) and each time I'm getting the same error.


    • Edited by bomberjim Wednesday, August 22, 2012 9:59 PM
    Wednesday, August 22, 2012 8:59 PM

All replies

  • Hello bomberjim,

    You're not alone. I have the same problem. Nightly backups all successful. I get "ERROR:  Could not load VDS" at each attempt. I also tried restoring to a USB HD with same results.

    My system is:

    Windows 7 Ultimate x64

    320 GB HD with the 2 partitions (system and OS)

    Does anyone have a solution?

    Thursday, August 23, 2012 1:34 PM
  • Hello bomberjim,

    Well, I figured it out.

    Our WHS 2011 server need to be tweeked.

    1. Enable the "COM+ Network Access (DCOM-In)" firewall inbound rule
    2. Enable the "COM+ Remote Administration (DCOM-In)" firewall inbound rule
    3. Enable the "Remote Volume Management - Virtual Disk Service (RPC)" firewall inbound rule
    4. Enable the "Remote Volume Management - Virtual DIsk Service Loader (RPC)" firewall inbound rule
    5. Enable the "Remote Volume Management (RPC-EPMAP)" firewall inbound rule

    I also played around with the "COM+ System Application"service, but with no definite conclusion as to it has to be enable or not.

    So my problem is fixed, but the real question is : Why do these firewall rules and service were not set appropriately with a standard WHS install?
    Is there some other settings that need to be set to enable these correctly?

    Hope this help.

    Saturday, August 25, 2012 1:49 AM
  • I got the same error.  Tried the firewall tweaks (and turned firewall off) and that didn't help me.

    My solution was to delete a partition which was immediately to the right of the C: partition I was trying to restore.  The notion I had was to give whs2011 all the room it needed to do the restore. That worked.  Luckily I had a work/scratch partition I could discard. I then recreated the removed partition. 

    Monday, September 3, 2012 5:33 PM
  • Thank you!  This worked perfectly.  
    Tuesday, August 27, 2013 11:11 PM
  • I have been having the same issue all afternoon, I had tried this and several other solutions none of which worked.

    Eventually I discovered that this is a known Microsoft issue and they have a work around...... here is the link:

    http://social.technet.microsoft.com/wiki/contents/articles/16126.client-bare-metal-restore-fails-due-to-vds-drive-initialization-fails.aspx?CommentPosted=true#commentmessage

    Friday, November 8, 2013 9:07 PM
  • I had to replace a client 500 gb single system disk with a new 1 tb disk.  I thought that this should be straightforward (this scenario is a major reason I use WHS 2011 right?), but I expected there to be a glitch and as usual there was. This error message.  After a few attempts I made it work by using Disk Manager to create a primary partition that exactly matched the size of the restore image.  Then I searched for this error out of curiosity and found this thread.  You know, it always seems as if scenario testing was simply not thorough enough.  I had a similar problem restoring the little system drive in my WHS server a couple of months ago.  It shouldn't be this hard. 

    • Edited by randym8888 Monday, February 17, 2014 1:53 AM
    Monday, February 17, 2014 1:51 AM