locked
Reinsall Help, Please RRS feed

  • Question

  • My Ethernet Port on the WHS motherboard was taken out by lightning.  I replaced the motherboard with the same type as the orig MB. 

    Life is good, except....  It appears that WHS wants to see the same MAC Adr on the Ethernet Port as the original installation... causes Remote console connection attempts to error out.  No provisions on the MB bios to change the MAC Adr.

    So I figured that a reinstall is necessary.  Tried that but I don't receive a reinstall option... only full install... end of attempt.  For some reason it can't see the existing installation... which functions as described above.

    I have read several forms with descriptions of:  1st, disconnect all but boot drive.  Do the full installation.  Power down, re-connect the drives, and boot.  The original installation will restore with no loss of files.

    Has anyone done this successfully? 

    My installation has two 1.5T and two 1T drives which comprise the last 5 years of my commercial photography files. 

    Thanks very much for the help,
    Emil




    Tuesday, September 22, 2009 6:44 PM

All replies

  • I don't have 5 years of commercial photography files, but, if I did I would read this FAQ very carefully about five times: http://social.microsoft.com/Forums/en-US/whsfaq/thread/cf354b5d-b37b-4b7f-a0d5-8e573697777f
    Wednesday, September 23, 2009 12:40 AM
  • I have read several forms with descriptions of:  1st, disconnect all but boot drive.  Do the full installation.  Power down, re-connect the drives, and boot.  The original installation will restore with no loss of files.



    the original installation will not restore without loss of data, if you do it that way. All data drives must be present during a server reinstall (and in this case you really need to choose a reinstall. not a new install). Details how the data is stored can be find in the FAQ linked in the previous posting.
    Independend of this you should always have one or more full backups of the shared folders to external drives and store at least one of them outside of the servers location to reduce the risk of total loss, if your server or the room in which it is located is hit by a disaster. Never rely on the server alone for critical data!

    Btw. I dont see a reinstallation scenario here
    . Did you install network drivers on the server (if the device is not showing up in Device Manager properly) and run discovery.exe in C:\Program Files\Windows Home Server on each client?? The MAC has nothing to do with name resolution not working, but obviously your server got a different IP address, so the clients need this kind of support.

    Best greetings from Germany
    Olaf
    Wednesday, September 23, 2009 9:02 AM
    Moderator
  • Don't try a reinstallation if you don't need to. Instead, on each of your client PCs, run C:\Program Files\Windows Home Server\discovery.exe
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 23, 2009 7:23 PM
    Moderator
  • Thanks for all the comments...

    All the files that 'put food on the table' are backed up on NAS and optical.  However, the organization and ease of access is best on the WHS server. 

    A project is backed up several times, the first being raw files go from the flash and sd cards to a battery run HD on site, and then minutes after I walk in the door... the raw files are immediately put on the NAS and my post processing work station.  During post processing all the files migrate down the backup path.  I also have enough flash and sd cards so that they are not erased until the orig RAW files are on optical.

    I have 1Gb Ethernet to WHS, but my NAS is only 100BaseT... and is entirely disconnected when not actually preforming a backup.

    ...and the optical... well, if you have a heavy drinking problem... and enjoy waiting for files to load... it's not useable for real time processing.  My 'photo files' are approx 130mb to well over 1GB and a few over 2GB.  So, the WHS is vital to timely work flow, and I would like to find some way to do a reinstall or a patch for MAC adr problem.

    So... with all that being said... my 'real time' work, as well as timely searches of past projects, is dependent on the organization and data on the WHS.  I really don't to start from scratch with a fresh install, if at all possible.

    Again, everything functions except the WHS Console.  I take exception with the statement that the MAC adr is

    irrelevant. 

    As I said, WHS reports a MAC adr error.  I guess I should have posted the exact error text...

    "Error while retrieving Mac Address:Object reference not set to an instance of the object."  In programming speak, it means we expected the MAC adr to be 'A' but we actually read 'B'.  I received the same error message on the old motherboard when I used a usb to ethernet adapter.

    Reinstalling the client software is not a solution.  I happens on the WHS box as well... but if I keep trying to open the WHS console on the server, repeatedly, it will finally open, but then I receive the same error message every 15 or 20 seconds.  However, it never will open the console on a client computer.

    I have reinstalled the connector on all my client computers.  All updates on all computers are current.  This weekend I migrated my Vista x64 box to Win7 x64 and the problem is identical on a fresh install of the Win7 client.  (Other clients reinstalled: 3 XP and 1 Vista boxes.)  If you're wondering about migrating to Win7 and the performance,etc ... don't... just do it, now. 

    Again.. WHS boots as expected... and all client access works as expected, even my Squeezebox server is running fine on the WHS box.

    The only problem is with the console.  I would like to understand why the reinstall option is not available... if there is another method to do a reinstall, or it there is a way to reconsile the MAC adr.


    Thanks very much,
    Emil


    Monday, October 5, 2009 1:32 PM
  • Hi Emil,
    if you use Remote Desktop to login to your server, does this work? Does the console start from there?

    Regarding the MAC address:
    People performed reinstalls on different hardware all the time and never have reported such a problem.

    If the MAC address is referenced this could be some cached data, maybe from your router?
    I had a long time the issue, that using nslookup against my router did return the wrong IP address for one of my servers (a firmware upgrade later fixed this).

    Can you post the output of the command
    ipconfig /all
    issued in a command prompt on both the server and a client PC?

    Best greetings from Germany
    Olaf
    Monday, October 5, 2009 1:51 PM
    Moderator
  • Why did you not use a PCI network card?
    rather than a new MOBO?
    Monday, October 5, 2009 5:39 PM
  • Thanks for the reply Tiberium.
    The mb is a very low power Atom dual processor... only one pci slot and that is being used for a 4-channel sata controller.  (I have constructed a somewhat unorthodox server, and that particular board was required to meet the design philosophy.)
    Emil


    Olaf,
    Thanks again... I checked the ipconfigs and everything is ok.  I have all resident devices assigned static devices and I manage devices on the network closely.

    I have decided to give up on the current install... a lack of time.  I borrowed an nas box and I will do a complete backup to it and then do a fresh install and restore.  My workload right involves printing and mounting, so I will move all the files I need to my printing computer.

    Thanks again for all the help, and really don't enjoy letting a problem pass by without finding out the solution.... but I will take the 'long' way around and start at first base again.  From a positive view point at least my work for the next few weeks will allow for the reinstall without a major inconvenience or loss of productivity.  Printing and mounting allows for plenty of time for babysitting installations.

    Thanks all,
    Emil
    Thursday, October 8, 2009 12:49 PM