none
Echo not deleting empty folders on right-side RRS feed

  • Question

  • I am wondering if the ECHO issue with file/folder being deleted on the right-side of a pair has been corrected.  I am using SyncToy 2.1, 32-bit.

     

    Daily, I run a Sync operation with left-folder of a server directory (\server\documents) and the right-side being my laptop (\laptop\documents).  After this is complete, as a backup, I run an Echo operation with the left-side being the same (\server\documents), but the right-side being an external drive (\external\documents).

     

    What I noticed yesterday, I renamed a folder on the server.  When I ran the Sync operation, it performed correctly, creating the new folder and deleting the old folder on right-side of the pair.

     

    When I ran the second (echo operation), it created the new folder on the right-side, but it did not delete the old folder on the right-side.

     

     I don’t know, if at all, how long this has been doing this.  I’m afraid that I may have a lot of empty folders on my external drive.

     

    Any ideas?  

    Tuesday, January 5, 2010 3:55 PM

All replies

  • Hi -

    Have you made any changes to the file/folder on the right side. One way to check this would be to change the sync option from "Echo" to "Synchronize" and then hit "Preview" ( be very careful to not hit the Synchronize button). This will then tell you what changes were made to the right that is now stopping us from deleting that folder ( files under the folder could have changed as well).

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, January 6, 2010 1:31 AM
    Moderator
  • No.  No changes to any files or folders are ever made on the external drive (right-side).  It is used only for backup purposes.  It is a USB connected external drive that is powered only once a day, when I run SyncToy.

     

    On the Sync pairs to my laptop.  Yes, I would make changes on my laptop when away from the office and sync with server when I return.

     

    I ran PREVIEW on the echo pairs like you asked (switch action from ECHO to SYNC) and the actions that it will do is create the deleted folders from the right-side to the left.  This is wrong, since these folders are empty and should have been deleted on the right when I previously ran the pairs in ECHO mode.

     

    I thought that maybe this issue just started happening after I recently upgraded to v2.1.  But in looking at the empty folders, these are very old, which lead me to believe that this problem has been going on for some time.

     

    In summary and in more detail, this is how I run SyncToy on a daily basis.  I run SyncToy in 3 phases.  I run them manually and ALWAYS run PREVIEW first.

     

    Phase 1: (action:left-side: right-side)

                sync: \server\personal: \laptop\personal

                sync: \server\work: \laptop\work

     

    Unless knowingly have done work on the right-side files (only when away from the office), I should expect never to see the right-side updating the left-side when previewing the actions.

     

    Phase 2: (action: left-side: right-side)

                echo: \server\personal: \external\personal

                echo: \server\work: \external\work

     

    Phase 3: (action: left-side: right-side)

                echo: \server\audio: \external\audio

                echo: \laptop\mydocuments\: \external\mydocuments

                echo: \server\media: \external\media

                echo: \server\pictures: \external\pictures

                echo: \server\video: \external\video

     

    An interesting issue also.  I changed the action items in Phase 3 from ECHO to SYNC and ran PREVIEW for those. Same issue - a large amount of empty folders.

     

     

     

    Wednesday, January 6, 2010 2:35 PM
  • I also have in the ECHO mode only file-deleting leaving empty folders and subfolders!
    It happens, dear Deepa, without any my actions on the right. It was the result of straight following a manual.
    For your attention VERY IMPORTANT INFO!
    Surprisingly, I didn`t meet this significant item in the guide. It is the conclusion of my small experience and experiments. I`m sure, this notice solve a major portion of user`s problems.
    So, for starting SyncToy for the first time NEVER create New Folder Pair between two folders with content, even identical.
    1. CREATE NEW EMPTY FOLDER FOR YOUR BACKUP and select it on the right side creating your New Folder Pair.
    2. Start up Synchronize or Echo and thereby fill this folder. SyncToy copying is faster, by the way.

    This is guarantee correct function in the sequel!
    Wednesday, January 6, 2010 3:48 PM
  • Any ideas?  I have not heard from you?

    I have a couple of clients using this in similar fashion with more important data.  I would like to know if this a problem.

    Thank you
    Friday, January 8, 2010 3:01 AM
  • What is the filesystem on your external drive? FAT/NTFS?

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Friday, January 8, 2010 9:59 PM
    Moderator
  • NTFS
    Saturday, January 9, 2010 5:59 PM
  • I can confirm that I am having the ECHO issue as well.  Renaming a folder on the left causes a new copy to be placed on the right while leaving the original right folder intact when it should have been deleted.  This occurred only after upgrading to v2.1.
    Sunday, January 10, 2010 3:59 AM
  • Can anyone recommend a suitable sync software?  Any experience or knowledge with BestSync 2010?

    I understand MS makes this software “as is” and hardware incompatibility issues aside, but if the product can not meet work at its most basic function, it should not be trusted.

    Sunday, January 10, 2010 10:35 PM