locked
CRM workflow not triggering RRS feed

  • Question

  • We are using CRM 5.0 online

    We are using a simple workflow under opportunity to calculate the forecasted weighted revenue (probability*Estimated rev.). On making a change in the probability field and select the "Save" option from the ribbon, the workflow is shown as succeeded but there is no change in the "forecasted weighted revenue" field.
    A change in this field only occurs when I select the "recalculate opportunity" option from the ribbon.

    Is there any way to ensure that the field will get updated on selecting the "save" option...??

    Thanks!

    Thursday, February 23, 2012 3:05 AM

Answers

  • How about Save > Wait > check workflow is succeeded > F5 to refresh (reload) form?

    Hope this helps Adam Vero, MCT

    • Marked as answer by boo oinky Thursday, March 1, 2012 4:59 AM
    Thursday, February 23, 2012 12:39 PM

All replies

  • In effect, it only work when :1) Save -> Recalculate Opportunity or
                                              2) Press Recalculate Opportunity twice
    But if I press either options only once, the page refreshes but there is no change in the field content
    Thursday, February 23, 2012 6:05 AM
  • Workflows are asynchronous. thats why you have to refresh or press those button agains to see the result. if you want to appear it straignt away then you nned to use javascript or plugins.

    I beleieve javascript is easier and quicker.

    I hope this helps.


    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer". Amreek Singh Senior CRM Consultant CDC Praxa Sydney, Australia http://mscrmshop.blogspot.com http://crm2011usersettings.codeplex.com

    • Proposed as answer by Amreek Singh Thursday, February 23, 2012 7:05 AM
    Thursday, February 23, 2012 7:05 AM
  • How about Save > Wait > check workflow is succeeded > F5 to refresh (reload) form?

    Hope this helps Adam Vero, MCT

    • Marked as answer by boo oinky Thursday, March 1, 2012 4:59 AM
    Thursday, February 23, 2012 12:39 PM
  • Thanks.. that works..
    Friday, February 24, 2012 2:11 AM