none
Carrige return and linefeed missing in Code

All replies

  • That's not a "bug", that's one of the many "cool features" (means "badly working things") in this forum... If you have a look at the HTML code, there are no line breaks but instead, they made each line a span element that receives its formatting from some CSS. If you copy the script, the CSS is missing and you get a scrambled script.

    In IE, sending the page via email (File - send - page by email) got me a working script - although it destroyed the german umlauts in the comments, but hey, who cares about umlauts? :-))


    Martin

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))

    Restore the forum design - my user defined Cascading Style Sheet!

    Tuesday, October 1, 2013 7:23 AM
  • Hi Martin!

    I have looked bevor your post, in the page HTML source and have reformated this.
    But... Is this what Microsoft will us force to do?

    We are priceless supporters for Microsoft Products, so I need good working tools from Microsoft.

    And the many Bugs and the new design in the Forum are very annoying.


    Meine PowerShell Artikel, Buchtipps und kostenlose PowerShell Tutorials + E-Books
    Mein deutscher PowerShell Blog
    Mein 21 Teiliger PowerShell Video Grundlehrgang
    Deutsche PowerShell Videos auf Youtube
    Folge mir auf:
    Twitter | Facebook | Google+ | Deutsches PowerShell Forum (TechNet)

    Tuesday, October 1, 2013 9:55 AM
  • That's the way it is today. MSFT did a forum redesign in June, and they almost completely ignore all the negative feedback for this new design... Seems like they are saying "love it or leave it, we don't care."

    Martin

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))

    Restore the forum design - my user defined Cascading Style Sheet!

    Tuesday, October 1, 2013 2:03 PM
  • I also frequently copy code to a text file when answering questions. I often need to spend considerable time "fixing" the code so I can read it (and possibly run it for testing). I don't know of any workaround. I may need to try Martin's idea of emailing the post to myself.


    Richard Mueller - MVP Directory Services

    Tuesday, October 1, 2013 3:04 PM
  • I am viewing this forum with IE10, I did a right-click and open in new tab on the link in the original question and saw the Powershell question in German.

    Then I selected a few lines from each of three blocks of code and pasted them into Notepad and also into Notepad++. I copied and pasted the whole of one code block. I also did a Select-All (Control-A) on the web page and pasted the whole web page. All the line breaks seemed to be handled correctly in each case.

    I cannot reproduce the problem described.

    Regards

    Adrian

    Wednesday, October 2, 2013 7:54 AM
  • Most here are using Firefox or Chrome due to the overloading of the Forums with CSS and Javascript. Maybe IE handles this line breaks ok, but hey, we are writing 2013 where a simple forum should be able to work with EVERY browser ;-)

    Martin

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))

    Restore the forum design - my user defined Cascading Style Sheet!

    Wednesday, October 2, 2013 9:35 AM
  • Hi Martin, thank you for that note about browser versions. I have only tried the copy and paste from IE10, none of the other posters in this thread mentioned Firefox or Chrome. Only one post had mentioned IE. When reporting faults or concerns with any software I think it is important to describe any pertinent issues including environments where the problem occurs and those where it does not.

    Regards

    Adrian

    Thursday, October 3, 2013 8:26 AM
  • My company is working with Firefox and IE 8 and 9.
     I am with Martin it MUST be possible to develop Internet pages that work with more then one Browser in one (newest) version!

    I like to hear a statement from the  TechNet Forum team.

    If the have this bug on thear list or not?

    If they are willing to fix this or leave us with this sad situation?

    Again. We are doing cost free support for Microsoft Products. So I need useful Tools or I will quit this painful job....


    Meine PowerShell Artikel, Buchtipps und kostenlose PowerShell Tutorials + E-Books
    Mein deutscher PowerShell Blog
    Mein 21 Teiliger PowerShell Video Grundlehrgang
    Deutsche PowerShell Videos auf Youtube
    Folge mir auf:
    Twitter | Facebook | Google+ | Deutsches PowerShell Forum (TechNet)

    Friday, October 25, 2013 7:44 AM
  • I have the same issu in this thread post:

    http://social.technet.microsoft.com/Forums/de-DE/5b1ba6e7-9c13-4198-a874-e3630350a30e/powershell-array-spalten?forum=powershell_de

    When do Microsoft think to resolve this ?

    I like to hear a statement from the  TechNet Forum team.

    If the have this bug on thear list or not?

    If they are willing to fix this or leave us with this sad situation?

    Again. We are doing cost free support for Microsoft Products. So I need useful Tools or I will quit this painful job....


    Meine PowerShell Artikel, Buchtipps und kostenlose PowerShell Tutorials + E-Books
    Mein deutscher PowerShell Blog
    Mein 21 Teiliger PowerShell Video Grundlehrgang
    Deutsche PowerShell Videos auf Youtube
    Folge mir auf:
    Twitter | Facebook | Google+ | Deutsches PowerShell Forum (TechNet)

    Tuesday, November 5, 2013 10:48 AM