Syncing outlook calendar with android calendar (HTC One X) RRS feed

  • Question

  • Hi all,

    This is causing me no end of frustration!! I hope I placed this message in the right place. Last year I managed to sync my outlook calendar with my android calendar. It worked pretty well for me since I use the calendar on my phone and it always updated to my outlook calendar very well. PC wise I'm running Windows 8.

    I recently reinstalled windows 8 on my machine and am having problems setting up the sync again. Once reinstalled I checked outlook again (via web) and when I go into 'Calendar settings' I can see my google calendar with the associated url. But for some reason it doesn't seem to work anymore. I'm also left with old events that I've deleted from the calendar in my android phone that haven't deleted in my windows calendar. This brings me onto another issue....I tried deleting the old events manually from windows calendar (both web and app) but couldn't figure out how to do it. It's not well designed.

    It seems in this day and age firms are so keen to get you by the balls i.e get an android phone which forces you to open a gmail account, use their calendar etc. Microsoft used to be so good but I'm rapidly using the will to live lol.

    Can anyone help me out with this please and explain how I can do this. I never use gmail but I know the sync between my android calendar and google calendar is fine. I'm quite happy to start from scratch.

    I'm wondering if the problem could be that I recently deleted a load of old items from my android calendar which are still in the windows calendar. Could anyone explain how to manually delete the old from the windows calendar. At least this might help with the re-syncing process.

    Thanks guys and any help would be greatly appreciated.


    Ian :-)

    Monday, February 3, 2014 8:00 PM

All replies

  • Hi Ian!!!

    I am so desperate for answers about my trusted devices/ syncing/ Windows 8.1/ 8.1 RT issues - I wind up here and see that basically.... anyone trying to sync anything on Windows 8 is screwed. It's like trying to run Java on my Surface RT. 

    The more I look for answers- the more problems I find. Just letting you know - been driving myself insane now for more than 2 months. You are NOT alone. LOL

    Three contacts with "support". Wow. I sure did read the MS thread on "Trusted Devices" Yup. Did that all on my own. 

    So... I leave you now to go enter a password somewhere for the 856X in like 4 hours.

    Tuesday, February 11, 2014 6:48 AM
  • This has long been an issue for me as I share multiple calendars (business, family, kids) with different people and they all need to be in synch.  My primary calendar is Outlook, but my shared calendars are on Google Calendar and I also use an Android device.

    After a lot of research, the best solution I could come up with was to use a MS Outlook add-in called gsyncit (, which will cost you $19.99.  It synchs your calendars both ways (make sure you set up the synching rules properly) and has the added benefit of synching all your Outlook/Andriod contacts, tasks and notes.  It's not perfect, but both my wife and I have been using it for the past year to synch our shared calendars and it's worked pretty well once figured out the correct synch parameters.  The way it works is Outlook-->Google-->Android and back again, though you also have the option of making Google your primary calendar and synching it with Outlook.

    One note of caution...  If you travel to different time zones, be very careful.  I'm not exactly sure what happened on a recent trip, but I think that my Android phone synched to my Google calendar before my computer reset to local time.  When it later synched, all of my Outlook calendar events were off by two hours and had to be reset manually.  It was a real pain, but at least I didn't lose any data.

    Good luck and here's hoping someone figures out an elegant solution to this problem.

    • Proposed as answer by catoman Tuesday, March 18, 2014 10:45 PM
    Tuesday, March 18, 2014 5:29 PM