locked
Performance Issue with MSCRM V3.0 RRS feed

  • Question

  •  

     

    Hi Friends,

    I am Prasad K a CRM consultant. We are GOLD CERTIFIED Partners with Microsoft.

    We need your assistance in resolving performance issues related to our Internal CRM implementation. We had the following configuration for CRM implementation at our location.

    ========================================================================
    Hardware Configuration
    ========================================================================
    Processor Configuration Intel XENON E5310, 1.66 GHz   
    No. of Processors       8     
    RAM configuration       8GB   

    ========================================================================
    Application Server Configuration      
    ========================================================================
    Web server Installed    IIS 6.0 for CRM V3.0  
    Frame work installed    Microsoft .net 1.1    
    Operating System        Windows 2003 Server enterprise edition with SP2

    ========================================================================
    Database Server Configuration 
    ========================================================================
    Database Server SQL Server 2000       
    No. of Users    50    

    ========================================================================

    Both, the application web server and database reside on the same server, and there is performance degradation during peak hours. The CRM users are both in India and in Global.

    The performance issue comes always with the global users who are accessing CRM via public IP, and sometimes with domestic users too.

    The following are the statistics that are observed with CRM users.

    ========================================================================

    Criteria                                                                             |  Domestic Users    | Global Users  
    ========================================================================

    Processing time for Page load                                              2-3 secs                 5 secs
    Processing time for to open existing instance of the entity      3-4 secs                 6-7 secs      
    Processing time for creating new instance                             2-3 secs                 4 secs
    ========================================================================

    I need your help in different ways to resolve this issue.


    Thanks in Advance,


    Prasad K.
    CRM Team.


    Wednesday, January 30, 2008 1:28 PM

Answers