none
As Admin I'm unable to edit & SAVE a system file RRS feed

  • Question

  • I recently installed WHS2011 and when I log in as Admin I'm noticing that there are lock icons on some folders.  As Admin, shouldn't I have "Full Control" of all folders & files?  What can I do to resolve this?

    For a current issue I'm trying to resolve...I signed on as Server Admin, I'm trying to edit an .xml file under "C:\Program Files\Windows Server\Bin\WebApps\Client\Package" and I'm able to Read the file and Edit it, however, I do not have Write access, so I'm unable to save the change.

    I looked at the ACL for C:\ drive & it shows that the Admin has Full Control for all of C:\, however, when I review the ACL for "C:\Program Files\Windows Server\Bin\WebApps\Client\Package\supportedOS.xml" for "Administrators", it ONLY has access enabled for "Read & Execute" and "Read".  These options are grayed out, therefore, I'm unable to update the access.

    How can I resolve this particular problem?  If I'm logged in as ADMIN, shouldn't I have access to ALL folders & files?

    Hope this provides enough details so others in the Forum can assist me.  If not, please let me know what additional information you might need.

    My apologies for these basic questions, but I would really appreciate anyones help to resolve this.  Thank you

    Saturday, March 3, 2012 6:47 PM

All replies

  • I'm on the road and so can't check my servers, but as I recall, certain files are intentionally locked away so that an end user can't make changes to them, even on purpose. There are various reasons for this; for the most part they will be files whose contents are critical to the correct operation of Windows Home Server. In the case of the file you're trying to change, I believe it contains settings which prevent the installation of the connector on unsupported operating systems (such as, for instance, Windows Server 2003 and 2008).

    Bottom line is that this is likely to be by design.


    I'm not on the WHS team, I just post a lot. :)

    Saturday, March 3, 2012 7:08 PM
    Moderator
  • Thank you for your response.  Yes, I'm having problems with the Connector and was just following the suggestions from Paul Andre, which appeared to resolve the problem for others.  Here's the forum link I'm referencing:
    http://social.microsoft.com/Forums/en-US/whsvailbeta/thread/352134db-6316-48d2-8367-1b5e3002b3c4

    Thanks for anyones help on how I can accomplish this.

    Saturday, March 3, 2012 10:22 PM
  • What's the original problem you are trying to resolve?


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Saturday, March 3, 2012 10:48 PM
  • I assume you're trying to get your Windows Home Server 2011 installation to back up another server? This is unsupported, and as I said previously I suspect Microsoft has intentionally locked down access to this file to prevent exactly what you're trying to do. You could try taking ownership of the file if you want to do it anyway, but speaking as an IT pro who's been responsible for designing and implementing disaster recovery plans, only a fool relies on any unsupported backup method, and if you're not going to rely on it, why bother in the first place?

    If you're having trouble installing on a supported operating system, that's a very different issue, and Paul's suggestion won't help you.


    I'm not on the WHS team, I just post a lot. :)


    Saturday, March 3, 2012 10:55 PM
    Moderator
  • Hi Phil, here's the original problems that I'm experiencing & looking to this forum for assistance...

    I have just installed WHS 2011 and I'm experiencing a couple issues with conectivity (i.e. Dashboard/Launchpad & Remote Access).

    Laptop (Win7 Enterprise SP1, 32-bit):
    When I first started up the WHS 2011 box everythings worked as expected.  By the next day or two, I couldn't connect to the server with the launchpad or dashboard (launchpad says the server is offline and the dashboard says a connection to the server cannot be found). Remote Access worked for another day and then it stopped working and I received certificate error suggesting security concern with the cert. Note: I wash performing a Remote Access from within my LAN.  What's strange is that I can still access the server's web page and network shares. 

    Desktop (Win7 Ultimate SP1, 64bit):
    I've not been able to connect to the WHS box at all with the launchpad or dashboard (launchpad says the server is offline and the dashboard says cannot connect this computer to the network) or via Remote Access where I get this error: "Your computer can't connect to the remote computer because the Remote Desktop Gateway server address requested and the certificate subject name do not match". However I can still access the server's web page and network shares.

    Let me know if any additional information is needed to help me trouble-shoot these connectivity problems.

    Thank you.



    • Edited by Jules1955 Monday, March 5, 2012 4:24 AM
    Sunday, March 4, 2012 10:28 PM
  • Any help with these problems would be greatly appreciated.  Thank you.
    Monday, March 5, 2012 4:46 PM