locked
Attempting to subscribe.. From Canada. RRS feed

  • Question

  •  

    I've had OneCare installed on my Vista x64 PC for quite a while now. I've tested everything, all my games work (important to me), and I'm really happy with the product. But, the free period is over, and I'd like to subscribe. So, I thought "this'll be easy... be right there, honey! I'm just going to activate this antivirus.. ".. .. Two hours of rubbing my face later? I'm no further ahead. Help!

     

    The problem:

     

    My Live Id knows I'm in Canada. It has all my billing info for x-box live, my msn stuff all says I'm in Canada.. My Windows LIve Account Summary shows clearly that, yes.. I live in Canada. Which, I do. Vancouver. Postal Code correct. Looking good.

     

    When I try to subscribe to Windows one care I am confronted by a page which wants my credit card info (fine) and billing information for said card. Annnnd It won't let me specify the country. It says "united states". Now, since two pages before this it informed me of the price for my subscription in Canadian Dollars... this is a bit vexing. I can't simply say "okay, I'm in Seattle" because a) it's a vicious lie, and b) it's not the billing info for my credit card.

     

    What to do? This is silly. I would phone and talk to somebody.. but... as many have pointed out: You Can't Get A Phone Number Unless You're A Subscriber. Help!

    Saturday, April 26, 2008 4:31 AM

Answers

  • ** Update **

    Turns out.. it's the Browswer language settings. I had to set it to English (Canada) .. and then the correct billing page popped up after restarting the browser and attempting to subscribe again.

     

     

     

    Saturday, April 26, 2008 4:20 PM

All replies

  • ** Update **

    Turns out.. it's the Browswer language settings. I had to set it to English (Canada) .. and then the correct billing page popped up after restarting the browser and attempting to subscribe again.

     

     

     

    Saturday, April 26, 2008 4:20 PM
  • Had the same problem from the UK.....

     

    I was pulling my hair out until your post pointed me in the right direction........how simple :-)

     

    Cheer buddy!

    Sunday, April 27, 2008 2:02 PM
  •  

    Question, I'm a bit techie challenged, so where or hoe do you change your browser setting? Is an msn seeting or an internet configuration?

     

    Thx!

    Monday, April 28, 2008 3:59 AM
  • It is not an MSN settings, it is part of the Internet Options for Internet Explorer.

     

    Open Internet Explorer and in Tools/Internet Options, verify that your language setting is correct for your country.

        If it is not, click "Add" to select your language and country combination from the list.

        Make that selection the default. It should appear at the top of the list.

        Remove or demote other entries that are not appropriate for your country.

     

    -steve

     

    Monday, April 28, 2008 1:14 PM
    Moderator
  • This sucks... there's no English (Singapore) option!!!

     

    So that means Singapore is excluded to subcribe to OneCare?

     

    The developer is just trying too hard to be clever to the point that it's stupid.

     

    Just put back the drop down list that everybody is using!

     

    Thursday, May 1, 2008 2:53 AM
  •  Chua.SG wrote:

    This sucks... there's no English (Singapore) option!!!

     

    So that means Singapore is excluded to subcribe to OneCare?

     

    The developer is just trying too hard to be clever to the point that it's stupid.

     

    Just put back the drop down list that everybody is using!

     

    In which countries and languages is Windows Live OneCare available?

    The Windows Live OneCare subscription service is available in the following countries and languages: Australia (English), Austria (German), Belgium (Dutch, French), Canada (English, French), France (French), Germany (German), Ireland (English), Italy (Italian), Japan (Japanese), Mexico (Spanish), Netherlands (Dutch), New Zealand (English), Singapore (English), Spain (Spanish), Switzerland (French, German), United Kingdom (English), United States (English, Spanish).

     

    I just opened the language setting in IE7 on my machine and I see:

    English (Singapore) [en-SG] in the list.

    What is your operating system language set to?

    -steve

    Thursday, May 1, 2008 12:35 PM
    Moderator
  • I'm using IE7 too. I tried looking at System language setting under the control but to no avail.

     

    BTW, I checked the systems at my work place and they have English [en-sg] listed as default. However, when I clicked on the add button, there's no English (Singapore) listed in the languages. How strange is that?

     

    Saturday, May 3, 2008 2:16 AM
  • Interesting. The setting for the language, as you've seen on the work PCs is in IE, not the system language in Control Panel.

    Are you using XP or Vista? About the only things I can think to try would be:

    1. Reset all IE settings to default on the advanced tab

    2. Reinstall IE7

     

    Or, send an email to support - they may have experience with this issue.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

     

    Saturday, May 3, 2008 2:31 AM
    Moderator
  • Thank you for this posting.  I have experienced the same problem, I've changed my settings, and will now attempt to subscribe from Canada

     

    Monday, June 23, 2008 11:43 AM