locked
Setting Permission To Delete Backup RRS feed

  • Question

  • With 2.0 Beta, I am unable to delete the backup folder. (External USB Hard Drive)

    I started to run backup to a new folder, but realized it gave it a new name and there would be no room left after for future backups.

    I was able to change permissions to delete the 1.6 backup, but the permissions for the 2.0 backup were all grayed out and couldn't be changed.

    How do I delete 2.0 backups?

    Thanks,

    Duane

    XP Home SP2, all updates.

    (It would be nice to have link to this forum in help.)
    Friday, September 7, 2007 3:17 PM

Answers

  • Duane, change the backup folder to a shared folder and allow all users to modify the files. You should then be able to delete the folder.

     

    Friday, September 7, 2007 3:49 PM
    Moderator

All replies

  • Duane, change the backup folder to a shared folder and allow all users to modify the files. You should then be able to delete the folder.

     

    Friday, September 7, 2007 3:49 PM
    Moderator
  • I changed it to a shared folder. When trying to delete I still get the same error saying I don't have permission.

     

    Saturday, September 8, 2007 5:22 AM
  • I restarted in Safe Mode and logged on as Administrator. The boxes were not all grayed out anymore (perhaps due to sharing). I then changed all permissions to deny and then back to allow. I was then able to delete folders. I did some other stuff with Owner tab, but I don't think it helped. If you have an XP Home machine, you may want to do further test to see exactly what steps should be taken. I can't believe I am the only one with this problem.

    Thanks,

    Duane

    Saturday, September 8, 2007 6:23 AM
  • I had the same problem.

    I had to clean up my external drive, but as I had to desinstall and reinstall WLOC 2, it is no big deal, but it takes some much time...

    The " can't save the back up and tune up settings" issue is not fixed at all. I've contacted the Support and they will investigate my case. There are a few bugs that need to be fixeb before releasing Windows Live One 2.

    Ben

    Saturday, September 8, 2007 4:55 PM
  • It is a big deal. Reinstalling is a last resort. It is a waste of time. If you use your computer contantly, such downtime is frustrating. You shouldn't have to uninstall just to delete a folder/file. PUT 2 or 3 warnings or more. This restart in safe mode is a poor work around. Then I can't go online if needed because my wireless adapter won't work in safe mode.

     

    Anyway, in 1.6 I could just change permissions in safe mode and the delete. It seems in 2.0 you have to enable sharing and then you can change permissions. You may have to change owner to administrator and check the box for child object, but I don't think that helped. Took a while and I was told to do a lot of other things first for what turned out to be fairly simple. (I wander if it will work next time - I delete and do a full backup every few months. At 80 gigs, it's hard to store more backups)

     

    Good Luck

    Duane

    Sunday, September 9, 2007 12:38 AM
  • I'm still running 1.6, and I've been wondering what the SOP is for maintaining backup folders.  If you use a USB ext. hard drive for backups, it's inevitable that you'll eventually have to clean out some old backups to avoid filling up the drive.  Surely standard procedure does not require booting to safe mode etc etc.

     

    So...  What should one do, both in 1.6 and 2.0 for routine maintenance of old backup files?  Building a new version would be a great opportunity to simplify the process.

     

    Cory

     

    Tuesday, September 11, 2007 12:12 AM
  • Ever since backup to anything other than CD/DVD was introduced in OneCare, we've requested a simple way to clean-up the backups. At this point, the only solution is manual per the FAQ post here - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=1698096&SiteID=2

     

    Thanks for adding to the discussion. I do agree that some sort of backup maintenance needs to be included in OneCare natively.

    -steve

    Tuesday, September 11, 2007 2:32 PM
    Moderator
  • I think this is a relevant thread to me, but I don't properly understand it.

     

    I tried OneCare, for the backup alone.  I backed to an external USB drive.  I quickly decided it wasn't suitable for me and uninstalled OneCare (this is because the files it creates are proprietary zips.  I want my backup to be a simple copy/mirror of my main files)   

     

    However, the Onecare backup files are still on the USB hard disk and I can't delete them, and there is no space on the hard disk for a further full backup.  I tried resetting the file properties from 'read-only', but it wouldn't let me.

     

    I don't want to reformat the drive, because many of my other backups are on it.

     

    I tried running the OneCare removal tool again with the USB drive attached, but it's made no difference.   How on earth do I get rid of these d*****d OneCare files?   It's starting to feel like NoCare to me!

     

    My free trial is now over (but it feel like my trials are continuing :-)

     

    Saturday, September 15, 2007 12:43 PM
  • Update:  I just discovered the FAQ:

    http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=1698096&SiteID=2

     

    This didn't appear when I originally searched for 'deleting onecare backup files'.  Basically it involves resetting the security permissions, not just file properties, something I wasn't aware of. 

     

    It looks like Sync Toy would actually meet my needs.

    I think this feature should be built into the operating system.

    Perhaps it already is?

    Saturday, September 15, 2007 1:03 PM
  • SyncToy isn't built into the OS, but can be downloaded from here - http://www.microsoft.com/windowsxp/using/digitalphotography/prophoto/synctoy.mspx

     

    I use it all the time for keeping folders synchronized both the external disks and other PCs.

    -steve

    Sunday, September 16, 2007 1:20 AM
    Moderator
  • I don't like synctoy because it doesn't delete folders.

    (Sorry, a little late responding)

    Saturday, November 3, 2007 4:39 AM
  • The beta of Synctoy 2 deletes folders during sync, but I've had a number of issues with the beta of Synctoy, so I can't recommend it yet. No need to apologize for a late reply, by the way. :-)

    -steve

     

    Sunday, November 4, 2007 6:26 PM
    Moderator
  • Duane,  Print this and follow the instructions,  There not perfect but its the best I can do without going into safe mode on my PC!

     

    FIRST: ensure to restore all files that you want to keep before deleting.

     

    SECOND: You need to reboot into safe mode and log in as administrator in order to change the file permissions in XP Home.

     

    • Immediately after your PC restarts keep pressing the F8 function key to get to your startup options.
    • When the menu appears select "Safe Mode" or "Safe Mode with Network Support"
    • When the login screen appears, Select "Administrator"
    • A dialog appears, click "YES"
    • Windows is now in safe mode.
      • Open "Windows Explorer" or "My Computer"
      • Navigate to the backup folder
      • Right click the backup folder and select "Properties"
      • I forgot the name of the tab, I think it's "Security" it's the tab you didn't see available in normal mode.
      • These are your user permissions.
        • Select "Administrators"
        • ensure "Full Access" is selected
        • Click "Apply"
        • Click "OK"

    You should now be able to delete the folder!

     

    Reboot into normal mode!  There is a bug in WLOC that will say your backup device is not available.  If you get this error do the following:

     

    Open WLOC:

      1.  Click change settings
      2. Select the backup tab
      3. Select the "Configure Backup" button
        • Select "Change Settings" button
        • Select your the PC you are configureing
        • Select "Change Location" under "Where"
        • Finaly select the drive you are backing up to.

     

    I noticed before I did this, WLOC displayed the correct drive for backup in the main window, but gave me the backup device not available error.  You just need to simply reselect the drive to get it working again, even though it may seem to be already pointing to the correct location!

     

    Wednesday, November 7, 2007 5:41 AM
  • You are getting the backup device not available error because the OneCare backup folder is not available. Configuring the backup again will create necessary folder and information in it.

    Thursday, November 8, 2007 6:23 AM
  • Cory, I have an external hard drive to back up my PC's hard drive so I sought the advice of Kim Komando and downloaded a free backup program. It is designed to back up only the critical data you need in case your hard drive crashes so your external replaces the files that were changed therefore maintaining the over all size of the back up. Obviously the back up will grow as we add new programs and files but should never get larger than our hard drive.

    I first had to clean up my external and delete all the unwanted data before I used the new back up program. I encountered the problem of not being able to delete files because there names were too long. In most cases I tried to delete folders but when I received the warning I would open the folder and attempt to delete the sub folders. I was able to delete the sub folders and thereby delete the original folder in most cases. After cleaning up the majority of the files I still had some I couldn't delete so I randomly tried something that cleaned the disk. I moved each of the undeleted sub folders to my "G" external drive and was able to delete every file on the external. It worked for me but can't say it will work for everyone.

     

    Kim Komando has a method of cleaning a hard drive sanitary before you dispose of it. Check her out and see which program she uses to do that.

     

    There has to be a better way but I don't know of it but will keep looking until I discover it.

    Wednesday, March 31, 2010 7:15 PM