none
Hard Drive Location Shows ATA instead of SATA RRS feed

  • Question

  • In my WHS console, my 2 SATA hard drives both show as Internal (ATA) for their location instead of SATA.

     

    I'm using a HP Workstation xw6200 for my WHS box.

     

    Are there any drivers or something in the BIOS that I have to adjust for it to display the hard drives location correctly?

    Tuesday, September 4, 2007 1:18 AM

All replies

  • Hi,

    In your BIOS setting, your sata setup as IDE olegecy or enhanced.

    To use it as sata, you need to RD to your WHS, install the drivers for your sata controller, then reboot to BIOS, and setup the drive as ACHI mode, the nWHS will see it as sata.

    Please notice, withgout installing the sata controller drivers in WHS, you will get problem booting your WHS.

    Also, sometimes not good idea to do that after your have working WHS, normally that done when installing the WHS first time, but in general, it ok.

    My best.
    Tuesday, September 4, 2007 1:50 AM
  • I'm not exactly sure which driver download I'll need under HP's support site for the SATA controller since none of them specifically appear to address it.

     

    Also, currently I do not see the option in the BIOS to change the drive's mode to ACHI.

    Tuesday, September 4, 2007 2:06 AM
  • Hi,

    What in BIOS for hard drive option you have?

    Can you give me the model of your HP and I will try to download the manual and see what drivers and BIOS setting.

    My best.
    Tuesday, September 4, 2007 2:40 AM
  •  defaultPlayer wrote:

    I'm using a HP Workstation xw6200 for my WHS box.

     

    Under "Storage" in my BIOS, I have the options for Device Configuration and Storage Options. Under Device Config it displays my HDD's and recognizes both having SATA connectors.

    Tuesday, September 4, 2007 2:45 AM
  • oops, sorry, oldie eyes here.

    Let me see if I can d/l the manual.

    My best.
    Tuesday, September 4, 2007 2:48 AM
  • No problem, thanks for your continued efforts.

     

    Tuesday, September 4, 2007 2:50 AM
  • Hi,

    Speaking of not easy to find what you are after in HP site Smile

    Well, from all the search, here:

    1 - In your bois, the setting for sata ACHI is as "Native Sata".

    2 - Ther are no win 2003 server for your controller from HP, it use intel chipset (Intel82801ER), but since i do not have the "part" number for your HP xw6200, it either the ICH5R or ICH6R, then it will be possible to download the windows 2003 server drivers from Intel.

    Can you do this search, or can I have the part number and I will search it for you?

    Some notice tho, I find many having problem regarding enabling the native sata even to install the drivers in XP and vista, but that general notice tho.

    My best.
    Tuesday, September 4, 2007 3:48 AM
  • Hi,

    Download this util from intel to know the chipset in your system:

    Intel Chipset Identification Utility

    My best.
    Tuesday, September 4, 2007 3:57 AM
  • Hmm..the Intel Chipset ID Utility doesn't want to indentify anything at all so that doesn't appear to be an option.

     

    Not to be the burden of bad news either..I have found nothing in the BIOS that refers to "Native SATA".

    Tuesday, September 4, 2007 4:23 AM
  • Hi,

    1 - Ok, xw6200 use intel ICH5R

    Then go to intel and download the windows 2003 server drivers there.

    2 - If you hit F10 (if that how you enter BIOS setup) then: Advanced - Device Options.

    Nothing about Sata there?

    If it is, see if "native sata" or something, but not RAID tho.

    I hope someone using same model or similar one and have the way to do that and could help here.

    My best.



    Tuesday, September 4, 2007 5:27 AM
  •  

    The only thing I see about SATA is for RAID under Advanced -> Device Options.

    Tuesday, September 4, 2007 9:50 PM
  • Hi,

    Till you the truth, I giveup to find the info myself, due to the poor HP support manual, I think I download like 25 one already.

    Can you post the issue in thier support forum regarding the BIOS setting for native sata and see if maybe someone help there.

    My best.


    Wednesday, September 5, 2007 2:25 AM
  • Thanks again for all your help anyways. I'm surprised you kept assisting me for as long as you did anyways

     

    If anyone else is using a HP Workstation that knows a solution for this issue, by all means post it here!

    Wednesday, September 5, 2007 4:46 AM
  •  

    Having the same problem "both show as Internal (ATA) for their location instead of SATA", everthing else is working fine on WHS using Escrow RTM, not rebuilding my WHS for another two weeks, so I will fix it when I get time and I will post back here when its fixed, possible problem could be fix in the BIOS maybe.

     

    Edit too add: I am not using a HP Workstation .

     

     

    Wednesday, September 5, 2007 5:55 PM
  •  Richard A Miller wrote:

     

    Having the same problem "both show as Internal (ATA) for their location instead of SATA", everthing else is working fine on WHS using Escrow RTM, not rebuilding my WHS for another two weeks, so I will fix it when I get time and I will post back here when its fixed, possible problem could be fix in the BIOS maybe.

     

    Edit too add: I am not using a HP Workstation .

     

     



    heh, Richard, when I quote your words, and just see the edit you did Smile

    Well, to the BIOS issue, first you need to update the drivers for your sata to your whs server after you RD to it or directly, then do the BIOS issue to change the sata option form legcy ide to ACHI option.

    I wonder why I post that to you, and I am 100% sure you know that issue already.

    My best.
    Wednesday, September 5, 2007 6:21 PM
  • Hi adobader.

     

    Thats the first thing I will try, but I'am going to do it in about 2 weeks, because everthing is running good on WHS, I need WHS now to hold some data (Music, Pictures, Recorded TV, My Docs) from XP, I'am installing Vista then will be reloading the XP data from WHS to the new Vista HDD.

    Wednesday, September 5, 2007 6:34 PM