locked
Can not add drive RRS feed

  • Question

  • I've been using WHS now for a few weeks and moved al my data to it recently,

    adding new drive always worked fine , until I wanted to add my last 500GB WD sata drive (promise TX4 controler)

    the drive was full of data so I did no imediatly added it to the storage pool but copied to the pool using RDP, when the drive was empty I wanted to add it using the console, the disk is shown but I can only press the remove button ???
    However the status of the disk is already "Not Added" .
    When I click remove I get "some file wil be permanently lost" although there is no data on the disk , I even removed the partition trough RDP disk managment.

    The total storage amount indicated by the managmant console however is indicating 1.5TB what can onl mean the disk was added in the fisrts place ? verry confusing...

    what should I do ??


    PS : I have 4 IDE drives and 2 sata drives , the sata drives are shown as SCSI

    Sunday, August 5, 2007 5:04 PM

All replies

  • I tried something else : phisicaly removed the 500GB WD that wouldn't add
    the total storage droped to 1.1TB
    Then I attached a 500GB seagate  , but it behaves axactly the same.

    IS there a maximum of 1+4 drives or something ?
     
    Sunday, August 5, 2007 11:29 PM
  • I am not sure if there is a maximum number of disks, but I have seen specs for systems running upto 19 disks on this forum. My own system has run 11 disks at once for a long period of time with no add/remove issues.

     

    I would suggest checking the WD disk in another computer, if there is no data on it try and do a full repartition and full format using disk manager in Windows. Do a scan disk as well.

     

    Assuming you have the right 2k3 server drivers for the card and motherboartd chipset, latest motherboard bios, latest SATA card bios check the following.....

    SATA cable 

    SATA card

    Power supply

     

    Cheers

    Monday, August 6, 2007 2:32 AM
  • Wel I'm sure its not the WD drive, as I replaced it by a seagate in it does exactly the same.
    The drive is in the storage pool , but the status is "not added"

    So I tried the remove function overnight (strange because the drive is empty)

    In the morning I got an unadded drive but now out of the storage pool and I could Add it , good news I thought

    So I added it to the pool , as this was the idea in the firts place. But as soon as it was added another disk , a 250GB ATA conected drive had now the not added status, but was in the pool. I also noticed some errors in the network health tab with some files .

    After some analyses with the disk managment console (RDP) I found out that when I was removing the 500GB seagate , he actualy removed the data from the 250GB Maxtor ??? all verry confusing.

    I also lost some files , not to manny , and recoverable , but this seems like a BUG to me.

    So , I added the 250 again , and now everything is running smoothly again.

    BUT WAT HAPPEND HERE ???

    Monday, August 6, 2007 11:03 AM
  • Hmmm

     

    Just had a similar problem, with SCSI drives.  I was having a personal glitch setting up SCSI addresses, but when I got that sorted out I added a Fujitsu 147G SCSI.  Powered up; all well.  Added the drive - fine.  Removed a smaller unit - fair amount of time spent juggling gigabytes - also fine.  Powered everything down again.  Took out the the small drive, put in two more Fujitsus.

     

    This time, both of the drives were showing as Status Not Added, but one was already in the main body of the Storage Table.  The other is showing Not Added in the top, where I expected it to be.  This one I added - no problem.  The other one only gives a Remove option - the Add option is greyed out.  It also threatens dire consequences (ie total data loss) if removed.

     

    So, in summary, I've added three suposedly identical drives.  One is coming up as Not Added.  The three drives are, puzzingly, showing slightly different descriptors.  They are OEM Fujitsu 68-pin, purchased together. 

     

    ModusLnk MXJ3147SC680600X SCSI Device    Not Added

    ModusLnk MXJ3147S680600X ML00002689       Healthy

    ModusLnk MXJ3147S680600X SCSI Device       Healthy

     

    I intend to leave everything cooking overnight and then pull the offending drive (whilst praying)...

    Monday, September 3, 2007 7:17 AM
  • Any resolution?

     

    I've got the exact same issue.  I added a SATA drive.  While it recognized the device, it wouldn't allow me to add it to the pool (status said "Not Added").  I removed it (despite the dire warnings), and found that after that process completed I could add the drive to the pool.  But my *other* drive of the same size and by the same mfr is now "Not Added"!

     

    I've poked around in the Control Panel of the computer and can't find any differences between the two drives from the system's perspective.  

    Saturday, February 2, 2008 9:01 PM
  • Just a thought or two

    from reading the forums on other issues - i think WHS has a reference to drives buried somewhere using GUID references and possibly in this case if you remove a drive then on shut down swap them for similar drives without a reboot in between you could be confusing WHS, especially if the drives are similar models from the same manufacturer?

    Could also de a driver issue in that its reporting to WHS that the same drive is there still when its not so WHS also could be confused

    Might be worth removing the drive in the console, then deleting the drivers (if you do not have other similar drives on your controller) reboot without swapping the drive but disconnect it, see if the console is reporting things correctly - if so, reboot and swap in the new drive, add drivers as necessary , add your disk to the pool and see if that solves your problems

    i have 11 drives in mine - 6 pata are same model plus 2 pata which are similar model just a few month younger - all seagate, i also have 2 samsung sata and one more sata seagate - they all report ok even though they all have similar pairs of names etc

    try loading the addin WHS Disk Managment "http://www.idolatry.org/uploads/WHSDiskMangement.msi" as this gives you a better clue which drive is which - especially as there is some confusion

    Should not happen i know but the above could explain to some extent what you are seeing

    Have not tried to remove a drive yet myself but added several over the last couple of months - did nothing special even added a couple with operating systems on them - worked fine they were just reformatted and added fine - may be just luck - we will see
    Sunday, February 3, 2008 12:36 PM