locked
certificate error when connecting to vail dashboard using ip address RRS feed

  • Question

  • "Hi"

    If i use https://xxxxx.homeserver.com i was able to connect to the dashboard ok from my work place,but recently they have started blocking the website  anything with home server.com.

    So i started using my ip address  eg https:// xxx.xxx.xx.xx   i can connect to my vail home page ,but when i try to connect to my dashboard i get the following

    Your computer can't connect to the remote computer because the Remote Desktop subject name do not match.contact your network administrator for assistance.

    Is there any way to get around this problem

    Thanks in advance

    Friday, October 22, 2010 1:29 AM

Answers

  • What about using a different Domain Name service provider? Under "Server settings" in the dashboard there is the option to choose an other service provider than homeserver.com, so perhaps you could try an unblocked domain. I didn't test it, but the option is available.
    • Marked as answer by dj8591 Thursday, October 28, 2010 12:08 AM
    Monday, October 25, 2010 2:09 PM
  • I have purchased different domain from godaddy eg. http://tesintg12.com  ,but over there i have to forward this domain to either  https://xxxxxx.homeserver.com  or to an ip address 

    https://xxx.xxx.xx.xx  .When i type  in the browser  hrttp://testing12.com itakes me back to https://xxxxxx.homeserver.com  or ip address https://xxx.xxx.xx.xx   back to sqare one .

    What you are sugesting is to  purchase domain name from the server itself from settings  remote accsess .I have gone that way but i was happy spending around $59  to find that it might not work.or affter few weeks workplace might block that web site again ,where the ip address can be changed at any time and has been working ok .

    • Marked as answer by dj8591 Thursday, October 28, 2010 12:08 AM
    Tuesday, October 26, 2010 3:23 AM
  • Please be aware that you're taking a risk if you work around restrictions your workplace puts on your Internet use. If they block homeserver.com, they don't want you accessing your home server, and doing so anyway is likely to be a fairly serious infraction of their workplace computing policy.
    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by dj8591 Thursday, October 28, 2010 12:09 AM
    Tuesday, October 26, 2010 12:56 PM
    Moderator
  • A certificate is always issued to a name, not to an IP address. So if you access a machine via IP address, the certificate will not match. (Its the same, as if you use the short name of your server internally.

    Also be aware, that the default Remote Desktop settings on Server 2008 R2 are restrictive in their default settings, so that this can be the reason, that your connection fails. (Check remote settings on the server and allow connection from any computer might help eventually.)

    Best greetings from Germany
    Olaf

    • Marked as answer by dj8591 Thursday, October 28, 2010 12:09 AM
    Tuesday, October 26, 2010 7:45 PM
    Moderator
  • I was hoping the Vail server  would  have fixed the the remote desktop problem which I have now for number of years  with my WHS 2003 ,because the Vail is running remote application program and does not use port 4125 ,3389 ,It uses only  80 and  https 443.There fore there no point me upgrading to VAIL server .The only program I have found so far that will work trough anything even from my workplace is LOGMEIN ,I have to take my hat of to those guys in logmein  team  but it’s only little bit to slow.

     

    Thanks very much gents /ladies for your time and effort, much appreciated

    • Marked as answer by dj8591 Thursday, October 28, 2010 12:09 AM
    Wednesday, October 27, 2010 4:39 AM

All replies

  • What about using a different Domain Name service provider? Under "Server settings" in the dashboard there is the option to choose an other service provider than homeserver.com, so perhaps you could try an unblocked domain. I didn't test it, but the option is available.
    • Marked as answer by dj8591 Thursday, October 28, 2010 12:08 AM
    Monday, October 25, 2010 2:09 PM
  • I have purchased different domain from godaddy eg. http://tesintg12.com  ,but over there i have to forward this domain to either  https://xxxxxx.homeserver.com  or to an ip address 

    https://xxx.xxx.xx.xx  .When i type  in the browser  hrttp://testing12.com itakes me back to https://xxxxxx.homeserver.com  or ip address https://xxx.xxx.xx.xx   back to sqare one .

    What you are sugesting is to  purchase domain name from the server itself from settings  remote accsess .I have gone that way but i was happy spending around $59  to find that it might not work.or affter few weeks workplace might block that web site again ,where the ip address can be changed at any time and has been working ok .

    • Marked as answer by dj8591 Thursday, October 28, 2010 12:08 AM
    Tuesday, October 26, 2010 3:23 AM
  • Please be aware that you're taking a risk if you work around restrictions your workplace puts on your Internet use. If they block homeserver.com, they don't want you accessing your home server, and doing so anyway is likely to be a fairly serious infraction of their workplace computing policy.
    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by dj8591 Thursday, October 28, 2010 12:09 AM
    Tuesday, October 26, 2010 12:56 PM
    Moderator
  • A certificate is always issued to a name, not to an IP address. So if you access a machine via IP address, the certificate will not match. (Its the same, as if you use the short name of your server internally.

    Also be aware, that the default Remote Desktop settings on Server 2008 R2 are restrictive in their default settings, so that this can be the reason, that your connection fails. (Check remote settings on the server and allow connection from any computer might help eventually.)

    Best greetings from Germany
    Olaf

    • Marked as answer by dj8591 Thursday, October 28, 2010 12:09 AM
    Tuesday, October 26, 2010 7:45 PM
    Moderator
  • I was hoping the Vail server  would  have fixed the the remote desktop problem which I have now for number of years  with my WHS 2003 ,because the Vail is running remote application program and does not use port 4125 ,3389 ,It uses only  80 and  https 443.There fore there no point me upgrading to VAIL server .The only program I have found so far that will work trough anything even from my workplace is LOGMEIN ,I have to take my hat of to those guys in logmein  team  but it’s only little bit to slow.

     

    Thanks very much gents /ladies for your time and effort, much appreciated

    • Marked as answer by dj8591 Thursday, October 28, 2010 12:09 AM
    Wednesday, October 27, 2010 4:39 AM