locked
loading webresources and/or iframes in dynamics crm 2013 sp1cu1 - browser not loading parallel RRS feed

  • Question

  • When Browsing in CRM in trace we can see that it waits to load instead of loading parallel.
    It only waits if there are iframes and webresource.
    When loading only the webresource or the iframe it is milliseconds.
    When loading the page with multiple iframes or webresource it waits until the first was loaded then loading the second and so on.

    Please vote for my request:

    https://connect.microsoft.com/dynamicssuggestions/feedbackdetail/view/1020784/loading-webresources-and-or-iframes-in-dynamics-crm-2013-sp1cu1-browser-not-loading-parallel


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Tuesday, November 4, 2014 3:13 PM

All replies

  • Are you sure you're not running into browser limitations?  IE, by default, only keeps two open requests to the same site open.  So it could be IE itself is queuing things because you have more than two items loading.  I'd check in other browsers like FireFox to see if it's getting the same behavior.  Also, use the FF dev tools to visualize it.

    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    Tuesday, November 4, 2014 5:34 PM
  • Hello Wayne,
    Yes for sure. Tested in IE9,10,11, chrome, firefox, opera. Tested with nothing except name and address field and put an iframe. Name and address loads parallel but iframe waits until address name was loaded, then iframe came up. Also tested in crm online, same behavior.
    So it should be by design?

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Tuesday, November 4, 2014 7:26 PM